summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_compress2
-rwxr-xr-xdh_perl2
3 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 222f5438..3fae5b73 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ debhelper (9.20130508) UNRELEASED; urgency=low
autoscript. Closes: #707159
* dh_installinfo: Stop inserting dependencies for partial upgrades
from lenny to squeeze. Closes: #707218
+ * dh_compress, dh_perl: Avoid failing if the package build directory does
+ not exist.
-- Joey Hess <joeyh@debian.org> Tue, 07 May 2013 19:42:52 -0400
diff --git a/dh_compress b/dh_compress
index 85cf2c89..ec07f85d 100755
--- a/dh_compress
+++ b/dh_compress
@@ -77,10 +77,12 @@ init();
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
+
my $compress=pkgfile($package,"compress");
# Run the file name gathering commands from within the directory
# structure that will be effected.
+ next unless -d $tmp;
my $olddir=getcwd();
verbose_print("cd $tmp");
chdir($tmp) || error("Can't cd to $tmp: $!");
diff --git a/dh_perl b/dh_perl
index bf2506c5..ddea2cd9 100755
--- a/dh_perl
+++ b/dh_perl
@@ -90,6 +90,8 @@ use constant XS_MODULE => 4;
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
+ next unless -d $tmp;
+
# Check also for alternate locations given on the command line
my @dirs = grep -d, map "$tmp/$_", $vendorlib, $vendorarch, @ARGV;