summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_compress3
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 344bc542..236649e9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.0.60) unstable; urgency=low
+
+ * dh_compress: After compressing an executable, changes the file mode to
+ 644. Executable .gz files are silly. Closes: #46383
+
+ -- Joey Hess <joeyh@master.debian.org> Wed, 6 Oct 1999 13:05:14 -0700
+
debhelper (2.0.59) unstable; urgency=low
* dh_installdocs: if $TMP/usr/share/doc/$PACKAGE is a broken symlink,
diff --git a/dh_compress b/dh_compress
index 1312bf46..a01f5d15 100755
--- a/dh_compress
+++ b/dh_compress
@@ -86,6 +86,9 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
if (@f) {
+ # Make executables not be anymore.
+ xargs(\@f,"chmod","a-x");
+
xargs(\@f,"gzip","-9f");
}