summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_shlibdeps4
2 files changed, 11 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 0bb44d67..de98ea7d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (9.20120609) UNRELEASED; urgency=low
+
+ * dh_shlibdeps: Warn if -V flag is passed, to avoid it accidentially being
+ used here rather than in dh_makeshlibs.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 05 Jul 2012 08:51:07 -0600
+
debhelper (9.20120608) unstable; urgency=low
* dh: When there's an -indep override target without -arch, or vice versa,
diff --git a/dh_shlibdeps b/dh_shlibdeps
index e941af6c..a41732fc 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -111,6 +111,10 @@ if ($dh{L_PARAMS}) {
$dh{L_PARAMS}=join(':', @paths);
}
+if (defined $dh{V_FLAG}) {
+ warning("You probably wanted to pass -V to dh_makeshlibs, it has no effect on dh_shlibdeps");
+}
+
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
my $ext=pkgext($package);