summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm12
-rw-r--r--debian/changelog6
2 files changed, 17 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index 702458c5..e109be57 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -58,7 +58,17 @@ sub configure {
sub install {
my $this=shift;
my $destdir=shift;
- $this->SUPER::install($destdir, "PREFIX=/usr", @_);
+
+ # Special case for Makefile.PL that uses
+ # Module::Build::Compat. PREFIX should not be passed
+ # for those; it already installs into /usr by default.
+ my $makefile=$this->get_sourcepath("Makefile");
+ if (system(qq{grep -q "generated automatically by MakeMaker" $makefile}) != 0) {
+ $this->SUPER::install($destdir, @_);
+ }
+ else {
+ $this->SUPER::install($destdir, "PREFIX=/usr", @_);
+ }
}
1
diff --git a/debian/changelog b/debian/changelog
index d4c7b750..fd9f147e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (7.3.6) UNRELEASED; urgency=low
+
+ * perl_makemaker: Re-add fix for #496157, lost in rewrite.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 22 Jul 2009 16:42:14 +0200
+
debhelper (7.3.5) experimental; urgency=low
[ Bernd Zeimetz ]