summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rwxr-xr-xdh11
-rwxr-xr-xdh_clean6
-rw-r--r--man/po4a/po/debhelper.pot33
-rw-r--r--man/po4a/po/es.po58
-rw-r--r--man/po4a/po/fr.po58
6 files changed, 86 insertions, 82 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index b46af58e..dceec786 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -118,7 +118,7 @@ sub END {
if ($cmd ne "dh_clean") {
foreach my $package (@{$dh{DOPACKAGES}}) {
my $ext=pkgext($package);
- open(LOG, ">>", "debian/${ext}log.debhelper") || error("failed to write to log");
+ open(LOG, ">>", "debian/${ext}debhelper.log") || error("failed to write to log");
print LOG $cmd."\n";
close LOG;
}
diff --git a/dh b/dh
index 215833f8..793146e6 100755
--- a/dh
+++ b/dh
@@ -29,7 +29,7 @@ used to set an option like "-v" or "-X" or "-N", as well as for more
specialised options.
Each debhelper command will record when it's successfully run in
-debian/package.log.debhelper. (Which dh_clean deletes.) So dh can tell
+debian/package.debhelper.log. (Which dh_clean deletes.) So dh can tell
which commands have already been run, for which packages, and skip running
those commands again.
@@ -367,7 +367,12 @@ sub run {
if (! $dh{NO_ACT}) {
my $ret=system($command, @options);
- exit($ret) if $ret != 0;
+ if ($ret >> 8 != 0) {
+ exit $ret >> 8;
+ }
+ elsif ($ret) {
+ exit 1;
+ }
}
}
@@ -376,7 +381,7 @@ sub loadlog {
my $ext=pkgext($package);
my @log;
- open(LOG, "<", "debian/${ext}log.debhelper");
+ open(LOG, "<", "debian/${ext}debhelper.log");
while (<LOG>) {
chomp;
push @log, $_;
diff --git a/dh_clean b/dh_clean
index cb1b9502..e20d988f 100755
--- a/dh_clean
+++ b/dh_clean
@@ -1,5 +1,5 @@
#!/usr/bin/perl -w
-
+exit 1;
=head1 NAME
dh_clean - clean up package build directories
@@ -73,6 +73,10 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# These are all debhelper temp files, and so it is safe to
# wildcard them.
complex_doit("rm -f debian/$ext*.debhelper");
+
+ if (! $dh{K_FLAG}) {
+ doit("rm","-f","debian/${ext}debhelper.log");
+ }
}
doit ("rm","-rf",$tmp."/")
diff --git a/man/po4a/po/debhelper.pot b/man/po4a/po/debhelper.pot
index 6cc3ebc0..8e102e7c 100644
--- a/man/po4a/po/debhelper.pot
+++ b/man/po4a/po/debhelper.pot
@@ -7,7 +7,7 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2008-04-23 21:06-0400\n"
+"POT-Creation-Date: 2008-04-23 21:24-0400\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"
@@ -16,7 +16,7 @@ msgstr ""
"Content-Transfer-Encoding: ENCODING"
# type: =head1
-#: debhelper.pod:1 dh_builddeb:3 dh_clean:3 dh_compress:3 dh_desktop:3 dh_fixperms:3 dh_gconf:3 dh_gencontrol:3 dh_installcatalogs:3 dh_installchangelogs:3 dh_installcron:3 dh_installdebconf:3 dh_installdeb:3 dh_installdirs:3 dh_installdocs:3 dh_installemacsen:3 dh_installexamples:3 dh_installinfo:3 dh_installinit:3 dh_installlogcheck:3 dh_installlogrotate:3 dh_installmanpages:3 dh_installman:3 dh_installmenu:3 dh_installmime:3 dh_installmodules:3 dh_installpam:3 dh_install:3 dh_installppp:3 dh_installwm:3 dh_installxfonts:3 dh_link:3 dh_listpackages:3 dh_makeshlibs:3 dh_md5sums:3 dh_movefiles:3 dh_perl:3 dh_python:3 dh_scrollkeeper:3 dh_shlibdeps:3 dh_strip:3 dh_suidregister:3 dh_testdir:3 dh_testroot:3 dh_testversion:3 dh_undocumented:3 dh_usrlocal:3
+#: debhelper.pod:1 dh_builddeb:3 dh_compress:3 dh_desktop:3 dh_fixperms:3 dh_gconf:3 dh_gencontrol:3 dh_installcatalogs:3 dh_installchangelogs:3 dh_installcron:3 dh_installdebconf:3 dh_installdeb:3 dh_installdirs:3 dh_installdocs:3 dh_installemacsen:3 dh_installexamples:3 dh_installinfo:3 dh_installinit:3 dh_installlogcheck:3 dh_installlogrotate:3 dh_installmanpages:3 dh_installman:3 dh_installmenu:3 dh_installmime:3 dh_installmodules:3 dh_installpam:3 dh_install:3 dh_installppp:3 dh_installwm:3 dh_installxfonts:3 dh_link:3 dh_listpackages:3 dh_makeshlibs:3 dh_md5sums:3 dh_movefiles:3 dh_perl:3 dh_python:3 dh_scrollkeeper:3 dh_shlibdeps:3 dh_strip:3 dh_suidregister:3 dh_testdir:3 dh_testroot:3 dh_testversion:3 dh_undocumented:3 dh_usrlocal:3
msgid "NAME"
msgstr ""
@@ -885,7 +885,7 @@ msgid ""
msgstr ""
# type: =head1
-#: debhelper.pod:494 dh_builddeb:85 dh_clean:116 dh_compress:189 dh_desktop:47 dh_fixperms:110 dh_gconf:90 dh_gencontrol:73 dh_installcatalogs:111 dh_installchangelogs:125 dh_installcron:61 dh_installdebconf:118 dh_installdeb:94 dh_installdirs:83 dh_installdocs:237 dh_installemacsen:109 dh_installexamples:103 dh_installinfo:103 dh_installinit:197 dh_installlogcheck:51 dh_installlogrotate:50 dh_installmanpages:197 dh_installman:249 dh_installmenu:80 dh_installmime:85 dh_installmodules:116 dh_installpam:52 dh_install:268 dh_installppp:56 dh_installwm:107 dh_installxfonts:86 dh_link:223 dh_listpackages:28 dh_makeshlibs:222 dh_md5sums:86 dh_movefiles:162 dh_perl:152 dh_python:282 dh_scrollkeeper:76 dh_shlibdeps:159 dh_strip:224 dh_suidregister:117 dh_testdir:43 dh_testroot:26 dh_testversion:74 dh_undocumented:28 dh_usrlocal:114
+#: debhelper.pod:494 dh_builddeb:85 dh_clean:121 dh_compress:189 dh_desktop:47 dh_fixperms:110 dh_gconf:90 dh_gencontrol:73 dh_installcatalogs:111 dh_installchangelogs:125 dh_installcron:61 dh_installdebconf:118 dh_installdeb:94 dh_installdirs:83 dh_installdocs:237 dh_installemacsen:109 dh_installexamples:103 dh_installinfo:103 dh_installinit:197 dh_installlogcheck:51 dh_installlogrotate:50 dh_installmanpages:197 dh_installman:249 dh_installmenu:80 dh_installmime:85 dh_installmodules:116 dh_installpam:52 dh_install:268 dh_installppp:56 dh_installwm:107 dh_installxfonts:86 dh_link:223 dh_listpackages:28 dh_makeshlibs:222 dh_md5sums:86 dh_movefiles:162 dh_perl:152 dh_python:282 dh_scrollkeeper:76 dh_shlibdeps:159 dh_strip:224 dh_suidregister:117 dh_testdir:43 dh_testroot:26 dh_testversion:74 dh_undocumented:28 dh_usrlocal:114
msgid "SEE ALSO"
msgstr ""
@@ -910,12 +910,12 @@ msgid "Debhelper web site."
msgstr ""
# type: =head1
-#: debhelper.pod:508 dh_builddeb:91 dh_clean:122 dh_compress:195 dh_desktop:53 dh_fixperms:116 dh_gconf:96 dh_gencontrol:79 dh_installcatalogs:117 dh_installchangelogs:131 dh_installcron:67 dh_installdebconf:124 dh_installdeb:100 dh_installdirs:89 dh_installdocs:243 dh_installemacsen:115 dh_installexamples:109 dh_installinfo:109 dh_installinit:203 dh_installlogcheck:57 dh_installlogrotate:56 dh_installmanpages:203 dh_installman:255 dh_installmenu:88 dh_installmime:91 dh_installmodules:122 dh_installpam:58 dh_install:274 dh_installppp:62 dh_installwm:113 dh_installxfonts:92 dh_link:229 dh_listpackages:34 dh_makeshlibs:228 dh_md5sums:92 dh_movefiles:168 dh_perl:158 dh_python:288 dh_scrollkeeper:82 dh_shlibdeps:165 dh_strip:230 dh_suidregister:123 dh_testdir:49 dh_testroot:32 dh_testversion:80 dh_undocumented:34 dh_usrlocal:120
+#: debhelper.pod:508 dh_builddeb:91 dh_clean:127 dh_compress:195 dh_desktop:53 dh_fixperms:116 dh_gconf:96 dh_gencontrol:79 dh_installcatalogs:117 dh_installchangelogs:131 dh_installcron:67 dh_installdebconf:124 dh_installdeb:100 dh_installdirs:89 dh_installdocs:243 dh_installemacsen:115 dh_installexamples:109 dh_installinfo:109 dh_installinit:203 dh_installlogcheck:57 dh_installlogrotate:56 dh_installmanpages:203 dh_installman:255 dh_installmenu:88 dh_installmime:91 dh_installmodules:122 dh_installpam:58 dh_install:274 dh_installppp:62 dh_installwm:113 dh_installxfonts:92 dh_link:229 dh_listpackages:34 dh_makeshlibs:228 dh_md5sums:92 dh_movefiles:168 dh_perl:158 dh_python:288 dh_scrollkeeper:82 dh_shlibdeps:165 dh_strip:230 dh_suidregister:123 dh_testdir:49 dh_testroot:32 dh_testversion:80 dh_undocumented:34 dh_usrlocal:120
msgid "AUTHOR"
msgstr ""
# type: textblock
-#: debhelper.pod:510 dh_builddeb:93 dh_clean:124 dh_compress:197 dh_fixperms:118 dh_gencontrol:81 dh_installchangelogs:133 dh_installcron:69 dh_installdebconf:126 dh_installdeb:102 dh_installdirs:91 dh_installdocs:245 dh_installemacsen:117 dh_installexamples:111 dh_installinfo:111 dh_installinit:205 dh_installlogrotate:58 dh_installmanpages:205 dh_installman:257 dh_installmenu:90 dh_installmime:93 dh_installmodules:124 dh_installpam:60 dh_install:276 dh_installppp:64 dh_installwm:115 dh_installxfonts:94 dh_link:231 dh_listpackages:36 dh_makeshlibs:230 dh_md5sums:94 dh_movefiles:170 dh_shlibdeps:167 dh_strip:232 dh_suidregister:125 dh_testdir:51 dh_testroot:34 dh_testversion:82 dh_undocumented:36
+#: debhelper.pod:510 dh_builddeb:93 dh_clean:129 dh_compress:197 dh_fixperms:118 dh_gencontrol:81 dh_installchangelogs:133 dh_installcron:69 dh_installdebconf:126 dh_installdeb:102 dh_installdirs:91 dh_installdocs:245 dh_installemacsen:117 dh_installexamples:111 dh_installinfo:111 dh_installinit:205 dh_installlogrotate:58 dh_installmanpages:205 dh_installman:257 dh_installmenu:90 dh_installmime:93 dh_installmodules:124 dh_installpam:60 dh_install:276 dh_installppp:64 dh_installwm:115 dh_installxfonts:94 dh_link:231 dh_listpackages:36 dh_makeshlibs:230 dh_md5sums:94 dh_movefiles:170 dh_shlibdeps:167 dh_strip:232 dh_suidregister:125 dh_testdir:51 dh_testroot:34 dh_testversion:82 dh_undocumented:36
msgid "Joey Hess <joeyh@debian.org>"
msgstr ""
@@ -983,21 +983,16 @@ msgid "Pass I<params> to L<dpkg-deb(1)> when it is used to build the package."
msgstr ""
# type: textblock
-#: dh_builddeb:87 dh_clean:118 dh_compress:191 dh_fixperms:112 dh_gconf:92 dh_gencontrol:75 dh_installcatalogs:113 dh_installchangelogs:127 dh_installcron:63 dh_installdebconf:120 dh_installdeb:96 dh_installdirs:85 dh_installdocs:239 dh_installemacsen:111 dh_installexamples:105 dh_installinfo:105 dh_installinit:199 dh_installlogcheck:53 dh_installlogrotate:52 dh_installmanpages:199 dh_installman:251 dh_installmime:87 dh_installmodules:118 dh_installpam:54 dh_install:270 dh_installppp:58 dh_installwm:109 dh_installxfonts:88 dh_link:225 dh_listpackages:30 dh_makeshlibs:224 dh_md5sums:88 dh_movefiles:164 dh_perl:154 dh_python:284 dh_strip:226 dh_suidregister:119 dh_testdir:45 dh_testroot:28 dh_testversion:76 dh_undocumented:30 dh_usrlocal:116
+#: dh_builddeb:87 dh_clean:123 dh_compress:191 dh_fixperms:112 dh_gconf:92 dh_gencontrol:75 dh_installcatalogs:113 dh_installchangelogs:127 dh_installcron:63 dh_installdebconf:120 dh_installdeb:96 dh_installdirs:85 dh_installdocs:239 dh_installemacsen:111 dh_installexamples:105 dh_installinfo:105 dh_installinit:199 dh_installlogcheck:53 dh_installlogrotate:52 dh_installmanpages:199 dh_installman:251 dh_installmime:87 dh_installmodules:118 dh_installpam:54 dh_install:270 dh_installppp:58 dh_installwm:109 dh_installxfonts:88 dh_link:225 dh_listpackages:30 dh_makeshlibs:224 dh_md5sums:88 dh_movefiles:164 dh_perl:154 dh_python:284 dh_strip:226 dh_suidregister:119 dh_testdir:45 dh_testroot:28 dh_testversion:76 dh_undocumented:30 dh_usrlocal:116
msgid "L<debhelper(7)>"
msgstr ""
# type: textblock
-#: dh_builddeb:89 dh_clean:120 dh_compress:193 dh_desktop:51 dh_fixperms:114 dh_gconf:94 dh_gencontrol:77 dh_installchangelogs:129 dh_installcron:65 dh_installdebconf:122 dh_installdeb:98 dh_installdirs:87 dh_installdocs:241 dh_installemacsen:113 dh_installexamples:107 dh_installinfo:107 dh_installinit:201 dh_installlogrotate:54 dh_installmanpages:201 dh_installman:253 dh_installmenu:86 dh_installmime:89 dh_installmodules:120 dh_installpam:56 dh_install:272 dh_installppp:60 dh_installwm:111 dh_installxfonts:90 dh_link:227 dh_listpackages:32 dh_makeshlibs:226 dh_md5sums:90 dh_movefiles:166 dh_perl:156 dh_python:286 dh_scrollkeeper:80 dh_shlibdeps:163 dh_strip:228 dh_suidregister:121 dh_testdir:47 dh_testroot:30 dh_testversion:78 dh_undocumented:32 dh_usrlocal:118
+#: dh_builddeb:89 dh_clean:125 dh_compress:193 dh_desktop:51 dh_fixperms:114 dh_gconf:94 dh_gencontrol:77 dh_installchangelogs:129 dh_installcron:65 dh_installdebconf:122 dh_installdeb:98 dh_installdirs:87 dh_installdocs:241 dh_installemacsen:113 dh_installexamples:107 dh_installinfo:107 dh_installinit:201 dh_installlogrotate:54 dh_installmanpages:201 dh_installman:253 dh_installmenu:86 dh_installmime:89 dh_installmodules:120 dh_installpam:56 dh_install:272 dh_installppp:60 dh_installwm:111 dh_installxfonts:90 dh_link:227 dh_listpackages:32 dh_makeshlibs:226 dh_md5sums:90 dh_movefiles:166 dh_perl:156 dh_python:286 dh_scrollkeeper:80 dh_shlibdeps:163 dh_strip:228 dh_suidregister:121 dh_testdir:47 dh_testroot:30 dh_testversion:78 dh_undocumented:32 dh_usrlocal:118
msgid "This program is a part of debhelper."
msgstr ""
# type: textblock
-#: dh_clean:5
-msgid "dh_clean - clean up package build directories"
-msgstr ""
-
-# type: textblock
#: dh_clean:14
msgid ""
"B<dh_clean> [S<I<debhelper options>>] [B<-k>] [B<-d>] [B<-X>I<item>] "
@@ -1040,13 +1035,13 @@ msgstr ""
# type: textblock
#: dh_clean:36
msgid ""
-"Do not delete debian/files. When do you want to use this? Anytime you have a "
-"debian/rules that has 2 binary targets that build different .deb packages; "
-"for example, one target is binary-arch, and the other is binary-indep, or "
-"one target builds the shared library, and the other the -dev package. If you "
-"didn't use -k in these cases, then debian/files would be deleted in the "
-"middle, and your changes file will only contain the last binary package that "
-"was built."
+"Do not delete debian/files, or files listed in debian/clean. When do you "
+"want to use this? Anytime you have a debian/rules that has 2 binary targets "
+"that build different .deb packages; for example, one target is binary-arch, "
+"and the other is binary-indep, or one target builds the shared library, and "
+"the other the -dev package. If you didn't use -k in these cases, then "
+"debian/files would be deleted in the middle, and your changes file will only "
+"contain the last binary package that was built."
msgstr ""
# type: =item
diff --git a/man/po4a/po/es.po b/man/po4a/po/es.po
index ad1bf31d..47c656a0 100644
--- a/man/po4a/po/es.po
+++ b/man/po4a/po/es.po
@@ -5,7 +5,7 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2008-04-23 21:06-0400\n"
+"POT-Creation-Date: 2008-04-23 21:24-0400\n"
"PO-Revision-Date: 2005-09-18 00:11+0200\n"
"Last-Translator: Rubén Porras Campo <debian-l10n-spanish@lists.debian.org>\n"
"Language-Team: SPANISH <debian-l10n-spanish@lists.debian.org>\n"
@@ -14,17 +14,17 @@ msgstr ""
"Content-Transfer-Encoding: ENCODING\n"
# type: =head1
-#: debhelper.pod:1 dh_builddeb:3 dh_clean:3 dh_compress:3 dh_desktop:3
-#: dh_fixperms:3 dh_gconf:3 dh_gencontrol:3 dh_installcatalogs:3
-#: dh_installchangelogs:3 dh_installcron:3 dh_installdebconf:3 dh_installdeb:3
-#: dh_installdirs:3 dh_installdocs:3 dh_installemacsen:3 dh_installexamples:3
-#: dh_installinfo:3 dh_installinit:3 dh_installlogcheck:3
-#: dh_installlogrotate:3 dh_installmanpages:3 dh_installman:3 dh_installmenu:3
-#: dh_installmime:3 dh_installmodules:3 dh_installpam:3 dh_install:3
-#: dh_installppp:3 dh_installwm:3 dh_installxfonts:3 dh_link:3
-#: dh_listpackages:3 dh_makeshlibs:3 dh_md5sums:3 dh_movefiles:3 dh_perl:3
-#: dh_python:3 dh_scrollkeeper:3 dh_shlibdeps:3 dh_strip:3 dh_suidregister:3
-#: dh_testdir:3 dh_testroot:3 dh_testversion:3 dh_undocumented:3 dh_usrlocal:3
+#: debhelper.pod:1 dh_builddeb:3 dh_compress:3 dh_desktop:3 dh_fixperms:3
+#: dh_gconf:3 dh_gencontrol:3 dh_installcatalogs:3 dh_installchangelogs:3
+#: dh_installcron:3 dh_installdebconf:3 dh_installdeb:3 dh_installdirs:3
+#: dh_installdocs:3 dh_installemacsen:3 dh_installexamples:3 dh_installinfo:3
+#: dh_installinit:3 dh_installlogcheck:3 dh_installlogrotate:3
+#: dh_installmanpages:3 dh_installman:3 dh_installmenu:3 dh_installmime:3
+#: dh_installmodules:3 dh_installpam:3 dh_install:3 dh_installppp:3
+#: dh_installwm:3 dh_installxfonts:3 dh_link:3 dh_listpackages:3
+#: dh_makeshlibs:3 dh_md5sums:3 dh_movefiles:3 dh_perl:3 dh_python:3
+#: dh_scrollkeeper:3 dh_shlibdeps:3 dh_strip:3 dh_suidregister:3 dh_testdir:3
+#: dh_testroot:3 dh_testversion:3 dh_undocumented:3 dh_usrlocal:3
msgid "NAME"
msgstr "NOMBRE"
@@ -1163,7 +1163,7 @@ msgstr ""
"puntos, p. ej.: DH_ALWAYS_EXCLUDE=CVS:.svn"
# type: =head1
-#: debhelper.pod:494 dh_builddeb:85 dh_clean:116 dh_compress:189 dh_desktop:47
+#: debhelper.pod:494 dh_builddeb:85 dh_clean:121 dh_compress:189 dh_desktop:47
#: dh_fixperms:110 dh_gconf:90 dh_gencontrol:73 dh_installcatalogs:111
#: dh_installchangelogs:125 dh_installcron:61 dh_installdebconf:118
#: dh_installdeb:94 dh_installdirs:83 dh_installdocs:237 dh_installemacsen:109
@@ -1199,7 +1199,7 @@ msgid "Debhelper web site."
msgstr "Web de Debhelper."
# type: =head1
-#: debhelper.pod:508 dh_builddeb:91 dh_clean:122 dh_compress:195 dh_desktop:53
+#: debhelper.pod:508 dh_builddeb:91 dh_clean:127 dh_compress:195 dh_desktop:53
#: dh_fixperms:116 dh_gconf:96 dh_gencontrol:79 dh_installcatalogs:117
#: dh_installchangelogs:131 dh_installcron:67 dh_installdebconf:124
#: dh_installdeb:100 dh_installdirs:89 dh_installdocs:243
@@ -1216,7 +1216,7 @@ msgid "AUTHOR"
msgstr "AUTOR"
# type: textblock
-#: debhelper.pod:510 dh_builddeb:93 dh_clean:124 dh_compress:197
+#: debhelper.pod:510 dh_builddeb:93 dh_clean:129 dh_compress:197
#: dh_fixperms:118 dh_gencontrol:81 dh_installchangelogs:133 dh_installcron:69
#: dh_installdebconf:126 dh_installdeb:102 dh_installdirs:91
#: dh_installdocs:245 dh_installemacsen:117 dh_installexamples:111
@@ -1313,7 +1313,7 @@ msgid "Pass I<params> to L<dpkg-deb(1)> when it is used to build the package."
msgstr "Pasa I<parámetros> a L<dpkg-deb(1)> cuando se construye el paquete."
# type: textblock
-#: dh_builddeb:87 dh_clean:118 dh_compress:191 dh_fixperms:112 dh_gconf:92
+#: dh_builddeb:87 dh_clean:123 dh_compress:191 dh_fixperms:112 dh_gconf:92
#: dh_gencontrol:75 dh_installcatalogs:113 dh_installchangelogs:127
#: dh_installcron:63 dh_installdebconf:120 dh_installdeb:96 dh_installdirs:85
#: dh_installdocs:239 dh_installemacsen:111 dh_installexamples:105
@@ -1328,7 +1328,7 @@ msgid "L<debhelper(7)>"
msgstr "L<debhelper(7)>"
# type: textblock
-#: dh_builddeb:89 dh_clean:120 dh_compress:193 dh_desktop:51 dh_fixperms:114
+#: dh_builddeb:89 dh_clean:125 dh_compress:193 dh_desktop:51 dh_fixperms:114
#: dh_gconf:94 dh_gencontrol:77 dh_installchangelogs:129 dh_installcron:65
#: dh_installdebconf:122 dh_installdeb:98 dh_installdirs:87 dh_installdocs:241
#: dh_installemacsen:113 dh_installexamples:107 dh_installinfo:107
@@ -1343,11 +1343,6 @@ msgid "This program is a part of debhelper."
msgstr "Este programa es parte de debhelper."
# type: textblock
-#: dh_clean:5
-msgid "dh_clean - clean up package build directories"
-msgstr "dh_clean - limpia los directorios de construcción de los paquetes"
-
-# type: textblock
#: dh_clean:14
msgid ""
"B<dh_clean> [S<I<debhelper options>>] [B<-k>] [B<-d>] [B<-X>I<item>] "
@@ -1398,14 +1393,15 @@ msgstr "B<-k>, B<--keep>"
# type: textblock
#: dh_clean:36
+#, fuzzy
msgid ""
-"Do not delete debian/files. When do you want to use this? Anytime you have a "
-"debian/rules that has 2 binary targets that build different .deb packages; "
-"for example, one target is binary-arch, and the other is binary-indep, or "
-"one target builds the shared library, and the other the -dev package. If you "
-"didn't use -k in these cases, then debian/files would be deleted in the "
-"middle, and your changes file will only contain the last binary package that "
-"was built."
+"Do not delete debian/files, or files listed in debian/clean. When do you "
+"want to use this? Anytime you have a debian/rules that has 2 binary targets "
+"that build different .deb packages; for example, one target is binary-arch, "
+"and the other is binary-indep, or one target builds the shared library, and "
+"the other the -dev package. If you didn't use -k in these cases, then debian/"
+"files would be deleted in the middle, and your changes file will only "
+"contain the last binary package that was built."
msgstr ""
"No elimina debian/files. ¿Cuándo usaría esta opción? Cuando un debian/rules "
"tenga dos objetivos binarios que construyen paquetes .deb diferentes; por "
@@ -5466,6 +5462,10 @@ msgid "Andrew Stribblehill <ads@debian.org>"
msgstr "Andrew Stribblehill <ads@debian.org>"
# type: textblock
+#~ msgid "dh_clean - clean up package build directories"
+#~ msgstr "dh_clean - limpia los directorios de construcción de los paquetes"
+
+# type: textblock
#~ msgid ""
#~ "See F</usr/share/doc/debhelper/examples/rules.multi> for an example of "
#~ "how to use this in a package that generates multiple binary packages."
diff --git a/man/po4a/po/fr.po b/man/po4a/po/fr.po
index bbce4372..756c57ac 100644
--- a/man/po4a/po/fr.po
+++ b/man/po4a/po/fr.po
@@ -3,7 +3,7 @@
msgid ""
msgstr ""
"Project-Id-Version: debhelper manpages\n"
-"POT-Creation-Date: 2008-04-23 21:06-0400\n"
+"POT-Creation-Date: 2008-04-23 21:24-0400\n"
"PO-Revision-Date: 2006-11-19 20:50+0100\n"
"Last-Translator: Valery Perrin <valery.perrin.debian@free.fr>\n"
"Language-Team: French <debian-l10n-french@lists.debian.org>\n"
@@ -13,17 +13,17 @@ msgstr ""
"X-Generator: KBabel 1.9.1\n"
# type: =head1
-#: debhelper.pod:1 dh_builddeb:3 dh_clean:3 dh_compress:3 dh_desktop:3
-#: dh_fixperms:3 dh_gconf:3 dh_gencontrol:3 dh_installcatalogs:3
-#: dh_installchangelogs:3 dh_installcron:3 dh_installdebconf:3 dh_installdeb:3
-#: dh_installdirs:3 dh_installdocs:3 dh_installemacsen:3 dh_installexamples:3
-#: dh_installinfo:3 dh_installinit:3 dh_installlogcheck:3
-#: dh_installlogrotate:3 dh_installmanpages:3 dh_installman:3 dh_installmenu:3
-#: dh_installmime:3 dh_installmodules:3 dh_installpam:3 dh_install:3
-#: dh_installppp:3 dh_installwm:3 dh_installxfonts:3 dh_link:3
-#: dh_listpackages:3 dh_makeshlibs:3 dh_md5sums:3 dh_movefiles:3 dh_perl:3
-#: dh_python:3 dh_scrollkeeper:3 dh_shlibdeps:3 dh_strip:3 dh_suidregister:3
-#: dh_testdir:3 dh_testroot:3 dh_testversion:3 dh_undocumented:3 dh_usrlocal:3
+#: debhelper.pod:1 dh_builddeb:3 dh_compress:3 dh_desktop:3 dh_fixperms:3
+#: dh_gconf:3 dh_gencontrol:3 dh_installcatalogs:3 dh_installchangelogs:3
+#: dh_installcron:3 dh_installdebconf:3 dh_installdeb:3 dh_installdirs:3
+#: dh_installdocs:3 dh_installemacsen:3 dh_installexamples:3 dh_installinfo:3
+#: dh_installinit:3 dh_installlogcheck:3 dh_installlogrotate:3
+#: dh_installmanpages:3 dh_installman:3 dh_installmenu:3 dh_installmime:3
+#: dh_installmodules:3 dh_installpam:3 dh_install:3 dh_installppp:3
+#: dh_installwm:3 dh_installxfonts:3 dh_link:3 dh_listpackages:3
+#: dh_makeshlibs:3 dh_md5sums:3 dh_movefiles:3 dh_perl:3 dh_python:3
+#: dh_scrollkeeper:3 dh_shlibdeps:3 dh_strip:3 dh_suidregister:3 dh_testdir:3
+#: dh_testroot:3 dh_testversion:3 dh_undocumented:3 dh_usrlocal:3
msgid "NAME"
msgstr "NOM"
@@ -1193,7 +1193,7 @@ msgstr ""
"dans DH_ALWAYS_EXCLUDE=CVS:.svn"
# type: =head1
-#: debhelper.pod:494 dh_builddeb:85 dh_clean:116 dh_compress:189 dh_desktop:47
+#: debhelper.pod:494 dh_builddeb:85 dh_clean:121 dh_compress:189 dh_desktop:47
#: dh_fixperms:110 dh_gconf:90 dh_gencontrol:73 dh_installcatalogs:111
#: dh_installchangelogs:125 dh_installcron:61 dh_installdebconf:118
#: dh_installdeb:94 dh_installdirs:83 dh_installdocs:237 dh_installemacsen:109
@@ -1230,7 +1230,7 @@ msgid "Debhelper web site."
msgstr "Le site internet de debhelper."
# type: =head1
-#: debhelper.pod:508 dh_builddeb:91 dh_clean:122 dh_compress:195 dh_desktop:53
+#: debhelper.pod:508 dh_builddeb:91 dh_clean:127 dh_compress:195 dh_desktop:53
#: dh_fixperms:116 dh_gconf:96 dh_gencontrol:79 dh_installcatalogs:117
#: dh_installchangelogs:131 dh_installcron:67 dh_installdebconf:124
#: dh_installdeb:100 dh_installdirs:89 dh_installdocs:243
@@ -1247,7 +1247,7 @@ msgid "AUTHOR"
msgstr "AUTEUR"
# type: textblock
-#: debhelper.pod:510 dh_builddeb:93 dh_clean:124 dh_compress:197
+#: debhelper.pod:510 dh_builddeb:93 dh_clean:129 dh_compress:197
#: dh_fixperms:118 dh_gencontrol:81 dh_installchangelogs:133 dh_installcron:69
#: dh_installdebconf:126 dh_installdeb:102 dh_installdirs:91
#: dh_installdocs:245 dh_installemacsen:117 dh_installexamples:111
@@ -1345,7 +1345,7 @@ msgstr ""
"Fournit les I<paramètres> à L<dpkg-deb(1)> lors de la construction du paquet."
# type: textblock
-#: dh_builddeb:87 dh_clean:118 dh_compress:191 dh_fixperms:112 dh_gconf:92
+#: dh_builddeb:87 dh_clean:123 dh_compress:191 dh_fixperms:112 dh_gconf:92
#: dh_gencontrol:75 dh_installcatalogs:113 dh_installchangelogs:127
#: dh_installcron:63 dh_installdebconf:120 dh_installdeb:96 dh_installdirs:85
#: dh_installdocs:239 dh_installemacsen:111 dh_installexamples:105
@@ -1360,7 +1360,7 @@ msgid "L<debhelper(7)>"
msgstr "L<debhelper(7)>"
# type: textblock
-#: dh_builddeb:89 dh_clean:120 dh_compress:193 dh_desktop:51 dh_fixperms:114
+#: dh_builddeb:89 dh_clean:125 dh_compress:193 dh_desktop:51 dh_fixperms:114
#: dh_gconf:94 dh_gencontrol:77 dh_installchangelogs:129 dh_installcron:65
#: dh_installdebconf:122 dh_installdeb:98 dh_installdirs:87 dh_installdocs:241
#: dh_installemacsen:113 dh_installexamples:107 dh_installinfo:107
@@ -1375,11 +1375,6 @@ msgid "This program is a part of debhelper."
msgstr "Ce programme fait partie de debhelper."
# type: textblock
-#: dh_clean:5
-msgid "dh_clean - clean up package build directories"
-msgstr "dh_clean - nettoie le répertoire de construction du paquet"
-
-# type: textblock
#: dh_clean:14
msgid ""
"B<dh_clean> [S<I<debhelper options>>] [B<-k>] [B<-d>] [B<-X>I<item>] "
@@ -1426,14 +1421,15 @@ msgstr "B<-k>, B<--keep>"
# type: textblock
#: dh_clean:36
+#, fuzzy
msgid ""
-"Do not delete debian/files. When do you want to use this? Anytime you have a "
-"debian/rules that has 2 binary targets that build different .deb packages; "
-"for example, one target is binary-arch, and the other is binary-indep, or "
-"one target builds the shared library, and the other the -dev package. If you "
-"didn't use -k in these cases, then debian/files would be deleted in the "
-"middle, and your changes file will only contain the last binary package that "
-"was built."
+"Do not delete debian/files, or files listed in debian/clean. When do you "
+"want to use this? Anytime you have a debian/rules that has 2 binary targets "
+"that build different .deb packages; for example, one target is binary-arch, "
+"and the other is binary-indep, or one target builds the shared library, and "
+"the other the -dev package. If you didn't use -k in these cases, then debian/"
+"files would be deleted in the middle, and your changes file will only "
+"contain the last binary package that was built."
msgstr ""
"Empêche la suppression de debian/files. Il faut utiliser cette option à "
"chaque fois que debian/rules comporte deux cibles différentes, entrainant la "
@@ -5595,6 +5591,10 @@ msgid "Andrew Stribblehill <ads@debian.org>"
msgstr "Andrew Stribblehill <ads@debian.org>"
# type: textblock
+#~ msgid "dh_clean - clean up package build directories"
+#~ msgstr "dh_clean - nettoie le répertoire de construction du paquet"
+
+# type: textblock
#~ msgid ""
#~ "See F</usr/share/doc/debhelper/examples/rules.multi> for an example of "
#~ "how to use this in a package that generates multiple binary packages."