summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rw-r--r--debhelper.pod3
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules4
-rwxr-xr-xdh_builddeb3
5 files changed, 15 insertions, 4 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 41b7a634..345630d7 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -45,7 +45,7 @@ sub init {
# Another way to set excludes.
if (exists $ENV{DH_ALWAYS_EXCLUDE} && length $ENV{DH_ALWAYS_EXCLUDE}) {
- push @{$dh{EXCLUDE}}, $ENV{DH_ALWAYS_EXCLUDE};
+ push @{$dh{EXCLUDE}}, split(":", $ENV{DH_ALWAYS_EXCLUDE});
}
# Generate EXCLUDE_FIND.
diff --git a/debhelper.pod b/debhelper.pod
index e1a589c7..56eb531a 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -376,6 +376,9 @@ tarball that (unwisely) includes CVS directories, you might want to export
DH_ALWAYS_EXCLUDE=CVS in debian/rules, to make it take effect wherever
your package is built.
+Multiple things to exclude can be separated with colons, as in
+DH_ALWAYS_EXCLUDE=CVS:.svn
+
=back
=head1 SEE ALSO
diff --git a/debian/changelog b/debian/changelog
index d2d11453..2222d3d8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.40) unstable; urgency=low
+
+ * Fix build with 077 umask. Closes: #187757
+ * Allow colons between multiple items in DH_ALWAYS_EXCLUDE.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 6 Apr 2003 14:30:48 -0400
+
debhelper (4.1.39) unstable; urgency=low
* Add calls to dh_installcatalogs to example rules files. Closes: #186819
diff --git a/debian/rules b/debian/rules
index 204cb5a1..ffb2c9ba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -39,9 +39,9 @@ build-stamp:
s/#LIST#/$$collect/; \
print; \
}; \
- }' `find . -type f -perm +1 -maxdepth 1 -name "dh_*" | sort` > debhelper.7
+ }' `find . -type f -perm +100 -maxdepth 1 -name "dh_*" | sort` > debhelper.7
# Turn all executables into man pages.
- find . -type f -perm +1 -maxdepth 1 -name "dh_*" \
+ find . -type f -perm +100 -maxdepth 1 -name "dh_*" \
-exec pod2man -c Debhelper -r "$(VERSION)" {} {}.1 \;
printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
Debian/Debhelper/Dh_Version.pm
diff --git a/dh_builddeb b/dh_builddeb
index a634be2e..3d9f9d86 100755
--- a/dh_builddeb
+++ b/dh_builddeb
@@ -60,7 +60,8 @@ else {
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
if (exists $ENV{DH_ALWAYS_EXCLUDE} && length $ENV{DH_ALWAYS_EXCLUDE}) {
- complex_doit("find $tmp -name $ENV{DH_ALWAYS_EXCLUDE} | xargs rm -rf");
+ complex_doit("find $tmp -name $_ | xargs rm -rf")
+ foreach split(":", $ENV{DH_ALWAYS_EXCLUDE});
}
doit("dpkg-deb", @{$dh{U_PARAMS}}, "--build", $tmp, $dh{DESTDIR}.$dh{FILENAME});
}