summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postrm-xfonts2
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
3 files changed, 9 insertions, 2 deletions
diff --git a/autoscripts/postrm-xfonts b/autoscripts/postrm-xfonts
index ce3b7c66..016a6392 100644
--- a/autoscripts/postrm-xfonts
+++ b/autoscripts/postrm-xfonts
@@ -5,7 +5,7 @@ for currentdir in $fontdirs; do
longdir=/usr/lib/X11/fonts/$currentdir
if [ -d $longdir ]; then
for file in fonts.dir fonts.alias; do
- rm -f $file
+ rm -f $longdir/$file
done
if [ $(find $longdir| wc -l) -eq 1 ]; then
rmdir -p $longdir
diff --git a/debian/changelog b/debian/changelog
index 799110d0..05c64c44 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.1.5) unstable; urgency=low
+
+ * dh_installxfonts: corrected a problem during package removal that was
+ silently neglecting to remove the fonts.dir/alias files.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2000 00:44:25 -0700
+
debhelper (2.1.4) unstable; urgency=low
* Whoops, I forgot to add v3 to cvs, so it was missing from a few
diff --git a/debian/control b/debian/control
index 3d25d433..1d0b0ad6 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl-5.005, fileutils (>= 4.0-2.1), file (>= 3.23-1)
-Standards-Version: 3.1.1.1
+Standards-Version: 3.2.0.0
Package: debhelper
Architecture: all