summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_shlibdeps26
2 files changed, 24 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index a76f417b..1337d61e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.0.17) unstable; urgency=low
+
+ * dh_shlibdeps: document that -l accepts multiple dirs, and
+ make multiple dirs absolute properly, not just the first.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 16 Apr 2001 23:20:30 -0700
+
debhelper (3.0.16) unstable; urgency=low
* Documented -isp, Closes: #93983
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 33fd9411..552687e4 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -40,13 +40,14 @@ passed to dpkg-shlibdeps. This will make their dependancies be ignored.
This may be useful in some situations, but use it with caution. This option
may be used more than once to exclude more than one thing.
-=item B<-l>I<directory>
+=item B<-l>I<directory>[:directory:directory:..]
-Before dpkg-shlibdeps is run, LD_LIBRARY_PATH will be set to the specified
-directory. This is useful for multi-binary packages where a library
-is built in one package and another package contains binaries linked
-against said library. Relative paths will be made absolute for the
-benefit of dpkg-shlibdeps.
+Before dpkg-shlibdeps is run, LD_LIBRARY_PATH will be set to the
+specified directory (or directories -- separate with colons). This is
+useful for multi-binary packages where a library is built in one
+package and another package contains binaries linked against said
+library. Relative paths will be made absolute for the benefit of
+dpkg-shlibdeps.
=back
@@ -77,10 +78,17 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (@filelist) {
if ($dh{L_PARAMS}) {
- # Force the path absolute.
- unless ($dh{L_PARAMS}=~m:^/:) {
- $dh{L_PARAMS}=getcwd()."/$dh{L_PARAMS}";
+ my @paths=();
+ foreach (split(/:/, $dh{L_PARAMS})) {
+ # Force the path absolute.
+ if (m:^/:) {
+ push @paths, $_;
+ }
+ else {
+ push @paths, getcwd()."/$_";
+ }
}
+ $dh{L_PARAMS}=join(':', @paths);
$ENV{'LD_LIBRARY_PATH'}=$dh{L_PARAMS};
verbose_print("LD_LIBRARY_PATH=$dh{L_PARAMS} \\");
}