summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_perl11
2 files changed, 6 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index 56f3b400..fe036d0a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,13 +1,14 @@
-debhelper (7.3.14) UNRELEASED; urgency=low
+debhelper (7.3.14) unstable; urgency=low
[ Colin Watson ]
- * dh: Add --list option to list available addons.
+ * dh: Add --list option to list available addons. Closes: #541302
[ Joey Hess ]
* Run pod2man with --utf8. Closes: #541270
* dh: Display $@ error if addon load fails. Closes: #541845
+ * dh_perl: Remove perl minimum dependency per new policy. Closes: #541811
- -- Colin Watson <cjwatson@debian.org> Thu, 13 Aug 2009 09:00:24 +0100
+ -- Joey Hess <joeyh@debian.org> Mon, 17 Aug 2009 15:55:48 -0400
debhelper (7.3.13) unstable; urgency=low
diff --git a/dh_perl b/dh_perl
index fbeee2d9..56d9f21a 100755
--- a/dh_perl
+++ b/dh_perl
@@ -60,9 +60,9 @@ directories by default.
=head1 CONFORMS TO
-Debian policy, version 3.0.1
+Debian policy, version 3.8.3
-Perl policy, version 1.18
+Perl policy, version 1.20
=cut
@@ -71,10 +71,6 @@ init();
my $vendorlib = substr $Config{vendorlib}, 1;
my $vendorarch = substr $Config{vendorarch}, 1;
-# the installation dir for arch-indep modules changed to
-# /usr/share/perl5 in this version:
-my $min_version = '5.6.0-16';
-
# Cleaning the paths given on the command line
foreach (@ARGV) {
s#/$##;
@@ -125,9 +121,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
unless $version;
$version = ">= $version";
}
- elsif ($deps & PM_MODULE) {
- $version = ">= $min_version";
- }
# no need to depend on an un-versioned perl-base -- it's
# essential