summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_installman6
2 files changed, 10 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index aa793616..f3c788c9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (5.0.20) unstable; urgency=low
+
+ * Minor bug fix from last release.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 23 Jan 2006 20:29:10 -0500
+
debhelper (5.0.19) unstable; urgency=low
* dh_installman: add support for --language option to override man page
diff --git a/dh_installman b/dh_installman
index df0ad44e..f054796c 100755
--- a/dh_installman
+++ b/dh_installman
@@ -148,8 +148,10 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# language code to the filename, so detect that and
# redirect to appropriate directory, stripping the code.
($langcode)=$basename=~m/.*\.([a-z][a-z](?:_[A-Z][A-Z])?)\.(?:[1-9]|man)/;
- # Strip the language code from the instname.
- $instname=~s/\.$langcode$//;
+ if (defined $langcode && $langcode ne '') {
+ # Strip the language code from the instname.
+ $instname=~s/\.$langcode$//;
+ }
}
elsif ($dh{LANGUAGE} ne 'C') {
$langcode=$dh{LANGUAGE};