summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Getopt.pm10
-rw-r--r--debian/changelog8
2 files changed, 13 insertions, 5 deletions
diff --git a/Debian/Debhelper/Dh_Getopt.pm b/Debian/Debhelper/Dh_Getopt.pm
index bddc06b8..2a5aa6c2 100644
--- a/Debian/Debhelper/Dh_Getopt.pm
+++ b/Debian/Debhelper/Dh_Getopt.pm
@@ -173,11 +173,11 @@ sub parseopts {
# dh through an override target to a command.
if (defined $ENV{DH_INTERNAL_OPTIONS}) {
@ARGV_extra=split_options_string($ENV{DH_INTERNAL_OPTIONS});
- my $ret=getoptions(\@ARGV_extra, $options);
- if (!$ret) {
- warning("warning: unknown options will be a fatal error in a future debhelper release");
- #error("unknown option; aborting");
- }
+ # Unknown options will be silently ignored.
+ my $oldwarn=$SIG{__WARN__};
+ $SIG{__WARN__}=sub {};
+ getoptions(\@ARGV_extra, $options);
+ $SIG{__WARN__}=$oldwarn;
# Avoid forcing acting on packages specified in
# DH_INTERNAL_OPTIONS. This way, -p can be specified
diff --git a/debian/changelog b/debian/changelog
index 4fe56307..3916f1ce 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,6 +18,14 @@ debhelper (7.3.0) UNRELEASED; urgency=low
-- Joey Hess <joeyh@debian.org> Mon, 20 Apr 2009 16:26:08 -0400
+debhelper (7.2.17) UNRELEASED; urgency=low
+
+ * Allow command-specific options to be passed to commands
+ via dh without causing other commands to emit a getopt
+ warning or deprecation message.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 12 Jun 2009 00:26:11 -0400
+
debhelper (7.2.16) unstable; urgency=low
* dh_gconf: Add missed half of postrm fragment removal. Closes: #531035