summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdh_auto_build1
-rwxr-xr-xdh_auto_clean1
-rwxr-xr-xdh_auto_configure1
-rwxr-xr-xdh_auto_install1
-rwxr-xr-xdh_auto_test1
5 files changed, 5 insertions, 0 deletions
diff --git a/dh_auto_build b/dh_auto_build
index a3c95211..75ce51cf 100755
--- a/dh_auto_build
+++ b/dh_auto_build
@@ -46,6 +46,7 @@ elsif (-e "setup.py") {
doit("python", "setup.py", "build", @{$dh{U_PARAMS}});
}
elsif (-e "Build.PL" && -e "Build") {
+ $ENV{MODULEBUILDRC} = "/dev/null";
doit("perl", "Build", @{$dh{U_PARAMS}});
}
diff --git a/dh_auto_clean b/dh_auto_clean
index 6c97b106..610155ae 100755
--- a/dh_auto_clean
+++ b/dh_auto_clean
@@ -60,6 +60,7 @@ elsif (-e "setup.py") {
doit('find', '.', '-name', '*.pyc', '-exec', 'rm', '{}', ';');
}
elsif (-e "Build.PL" && -e "Build") {
+ $ENV{MODULEBUILDRC} = "/dev/null";
doit("perl", "Build", "--allow_mb_mismatch", 1, "distclean", @{$dh{U_PARAMS}});
}
diff --git a/dh_auto_configure b/dh_auto_configure
index 6b8adf52..41f6210f 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -92,6 +92,7 @@ elsif (-e "Makefile.PL") {
}
elsif (-e "Build.PL") {
$ENV{PERL_MM_USE_DEFAULT}=1; # Module::Build can also use this.
+ $ENV{MODULEBUILDRC} = "/dev/null";
doit("perl", "Build.PL", "installdirs=vendor", @{$dh{U_PARAMS}});
}
diff --git a/dh_auto_install b/dh_auto_install
index 8e7ab907..264725ca 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -90,6 +90,7 @@ elsif (-e "setup.py") {
@{$dh{U_PARAMS}});
}
elsif (-e "Build.PL" && -e "Build") {
+ $ENV{MODULEBUILDRC} = "/dev/null";
doit("perl", "Build", "install", "destdir=$destdir",
"create_packlist=0", @{$dh{U_PARAMS}});
}
diff --git a/dh_auto_test b/dh_auto_test
index 05c11b22..baccd10a 100755
--- a/dh_auto_test
+++ b/dh_auto_test
@@ -55,6 +55,7 @@ if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
}
}
elsif (-e "Build.PL" && -e "Build") {
+ $ENV{MODULEBUILDRC} = "/dev/null";
doit(qw/perl Build test/, @{$dh{U_PARAMS}});
}