summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdh_strip6
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index d8d86b59..81f7c6d4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,8 +4,10 @@ debhelper (5.0.55) UNRELEASED; urgency=low
files with MimeType fields. Patch from Emmet Hikory. Closes: #427831
* dh_strip: Don't run objcopy if the output file already exists.
Closes: #380314
+ * dh_strip: Check that --dbg-package lists the name of a real package.
+ Closes: #442480
- -- Joey Hess <joeyh@debian.org> Thu, 13 Sep 2007 15:47:55 -0400
+ -- Joey Hess <joeyh@debian.org> Sun, 16 Sep 2007 19:47:59 -0400
debhelper (5.0.54) unstable; urgency=low
diff --git a/dh_strip b/dh_strip
index ef91d651..2c7f3d8f 100755
--- a/dh_strip
+++ b/dh_strip
@@ -181,7 +181,11 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$keep_debug=1;
# Note that it's only an array for the v4 stuff;
# for v5 only one value is used.
- $debugtmp=tmpdir(@{$dh{DEBUGPACKAGES}}[0]);
+ my $debugpackage=@{$dh{DEBUGPACKAGES}}[0];
+ if (! grep { $_ eq $debugpackage } getpackages()) {
+ error("debug package $debugpackage is not listed in the control file");
+ }
+ $debugtmp=tmpdir($debugpackage);
}
}
else {