summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_shlibdeps2
-rwxr-xr-xdh_suidregister2
4 files changed, 6 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index fcaa4fdc..f9bb33d9 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
# List of files of dh_* commands. Sorted for debhelper man page.
-COMMANDS=$(shell find . -maxdepth 1 -type f -perm +100 -name "dh_*" -printf "%f\n" | sort)
+COMMANDS=$(shell find . -maxdepth 1 -type f -perm /100 -name "dh_*" -printf "%f\n" | sort)
# Find deprecated commands by looking at their synopsis.
DEPRECATED=$(shell egrep -l '^dh_.* - .*deprecated' $(COMMANDS))
@@ -50,7 +50,7 @@ LANGS=
endif
build: version debhelper.7
- find . -maxdepth 1 -type f -perm +100 -name "dh*" \
+ find . -maxdepth 1 -type f -perm /100 -name "dh*" \
-exec $(POD2MAN) {} {}.1 \;
ifneq ($(USE_NLS),no)
po4a --previous -L UTF-8 man/po4a/po4a.cfg
diff --git a/debian/changelog b/debian/changelog
index b20ff924..efe0f06a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -25,6 +25,8 @@ debhelper (9.20120609) UNRELEASED; urgency=low
Closes: #690399 Thanks, Michael Stapelberg
* Updated French man page translation. Closes: #692208
* dh_icons: Reword description. Closes: #693100
+ * Avoid find -perm +mode breakage caused by findutils 4.5.11,
+ by instead using -perm /mode. Closes: #700200
-- Joey Hess <joeyh@debian.org> Thu, 05 Jul 2012 08:51:07 -0600
diff --git a/dh_shlibdeps b/dh_shlibdeps
index a41732fc..260a749a 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -133,7 +133,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (defined($dh{EXCLUDE_FIND}) && $dh{EXCLUDE_FIND} ne '') {
$find_options="! \\( $dh{EXCLUDE_FIND} \\)";
}
- foreach my $file (split(/\n/,`find $tmp -type f \\( -perm +111 -or -name "*.so*" -or -name "*.cmxs" \\) $find_options -print`)) {
+ foreach my $file (split(/\n/,`find $tmp -type f \\( -perm /111 -or -name "*.so*" -or -name "*.cmxs" \\) $find_options -print`)) {
# Prune directories that contain separated debug symbols.
next if $file=~m!^\Q$tmp\E/usr/lib/debug/(lib|lib64|usr|bin|sbin|opt|dev|emul)/!;
# TODO this is slow, optimize. Ie, file can run once on
diff --git a/dh_suidregister b/dh_suidregister
index 7f6cd40f..893eb3dd 100755
--- a/dh_suidregister
+++ b/dh_suidregister
@@ -53,7 +53,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (! @files && ! $suid) {
# No files specified (and no empty debian/suid file), so
# guess what files to process.
- @files=split(/\n/,`find $tmp -type f -perm +6000`);
+ @files=split(/\n/,`find $tmp -type f -perm /6000`);
# Strip the debian working directory off of the filenames.
$tostrip="$tmp/";