summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_gencontrol9
2 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ebcb3818..96582500 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ debhelper (7.0.18) UNRELEASED; urgency=low
* dh_installchangelogs: Fall back to looking for changelog files ending
with ".txt". Closes: #498460
+ * dh_gencontrol: Ensure misc:Depends is set in substvars to avoid dpkg
+ complaining about it when it's empty. Closes: #498666
-- Joey Hess <joeyh@debian.org> Wed, 10 Sep 2008 13:58:00 -0400
diff --git a/dh_gencontrol b/dh_gencontrol
index 785586f9..268ab3a0 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -42,6 +42,8 @@ init();
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
my $ext=pkgext($package);
+
+ my $substvars="debian/${ext}substvars";
my $changelog=pkgfile($package,'changelog');
if (! $changelog) {
@@ -52,6 +54,11 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
doit("install","-o",0,"-g",0,"-d","$tmp/DEBIAN");
}
+ # avoid gratuitous warning
+ if (! -e $substvars || system("grep -q '^misc:Depends=' $substvars") != 0) {
+ complex_doit("echo misc:Depends= >> $substvars");
+ }
+
# Generate and install control file.
my @command="dpkg-gencontrol";
if (getpackages() > 1) {
@@ -61,7 +68,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
push @command, "-UHomepage";
push @command, "-n".udeb_filename($package);
}
- doit(@command, "-l$changelog", "-Tdebian/${ext}substvars",
+ doit(@command, "-l$changelog", "-T$substvars",
"-P$tmp",@{$dh{U_PARAMS}});
# This chmod is only necessary if the user sets the umask to