summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xdh_clean11
2 files changed, 8 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 66f4af2a..767af640 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,8 +2,11 @@ debhelper (5.0.4) UNRELEASED; urgency=low
* Remove hardcoded pathc to update-modules and gconf-schemas in various
script fragments.
+ * dh_clean: Patch from Matej Vela to clean up autom4te.cache directories
+ in subdiretories of the source tree and do it all in one enormous,
+ evil, and fast find expression. Closes: #338193
- -- Joey Hess <joeyh@debian.org> Tue, 8 Nov 2005 16:02:09 -0500
+ -- Joey Hess <joeyh@debian.org> Tue, 8 Nov 2005 16:16:56 -0500
debhelper (5.0.3) unstable; urgency=low
diff --git a/dh_clean b/dh_clean
index 0fb3464a..18c298df 100755
--- a/dh_clean
+++ b/dh_clean
@@ -87,20 +87,17 @@ if (! $dh{D_FLAG}) {
# See if some files that would normally be deleted are excluded.
my $find_options='';
if (defined($dh{EXCLUDE_FIND}) && $dh{EXCLUDE_FIND} ne '') {
- $find_options="-a ! \\( $dh{EXCLUDE_FIND} \\)";
+ $find_options="! \\( $dh{EXCLUDE_FIND} \\) -a";
}
# Remove other temp files.
- complex_doit("find . -type f -a \\
+ complex_doit("find . $find_options \\( \\( -type f -a \\
\\( -name '#*#' -o -name '.*~' -o -name '*~' -o -name DEADJOE \\
-o -name '*.orig' -o -name '*.rej' -o -name '*.bak' \\
-o -name '.*.orig' -o -name .*.rej -o -name '.SUMS' \\
-o -name TAGS -o -name core -o \\( -path '*/.deps/*' -a -name '*.P' \\) \\
- \\) $find_options -exec rm -f {} \\;");
-
- # Stupid autoconf cache directory.
- doit("rm", "-rf", "autom4te.cache")
- unless excludefile("autom4te.cache");
+ \\) -exec rm -f {} \\; \\) -o \\
+ \\( -type d -a -name autom4te.cache -prune -exec rm -rf {} \\; \\) \\)");
}
doit('rm', '-rf', 'debian/tmp') if -x 'debian/tmp' && ! compat(1) &&