summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_usrlocal4
2 files changed, 3 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index f0ec9c36..bb394f4c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-debhelper (4.9.5) UNRELEASED; urgency=low
+debhelper (4.9.5) unstable; urgency=low
* dh_install: in v5 mode, error out if there are wildcards in the file
list and the wildcards expand to nothing. Done only for v5 as this is a
diff --git a/dh_usrlocal b/dh_usrlocal
index edfc0aa1..f13c58fa 100755
--- a/dh_usrlocal
+++ b/dh_usrlocal
@@ -99,13 +99,13 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# This constructs the body of a 'sed' c\ expression which
# is parsed by the shell in double-quotes
my $dirs = join("$ebs\n", @dirs);
- pop @justdirs; # don't remove directories in /usr/local
+ pop @justdirs; # don't remove directories directly in /usr/local
my $justdirs = join("$ebs\n", @justdirs);
if (! $dh{NOSCRIPTS}) {
autoscript($package,"postinst", "postinst-usrlocal",
"/#DIRS#/ c${ebs}\n${dirs}");
autoscript($package,"prerm", "prerm-usrlocal",
- "/#JUSTDIRS#/ c${ebs}\n${justdirs}");
+ "/#JUSTDIRS#/ c${ebs}\n${justdirs}") if length $justdirs;
}
}
}