summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rwxr-xr-xdebian/rules2
-rwxr-xr-xdh_installudev3
-rwxr-xr-xdh_installxfonts12
-rw-r--r--man/po4a/po/debhelper.pot6
-rw-r--r--man/po4a/po/es.po7
-rw-r--r--man/po4a/po/fr.po7
7 files changed, 30 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index 056ff7e4..70988e64 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,7 +8,17 @@ debhelper (5.0.31) UNRELEASED; urgency=low
* Change build-depends for po4a. New version (0.24.1).
* Add code for removing empty "lang" directories into man/ when cleaning.
- -- Joey Hess <joeyh@debian.org> Fri, 14 Apr 2006 11:04:23 +0200
+ [ Joey Hess ]
+ * dh_installxfonts: pass --x11r7-layout to update-fonts-* commands to ensure
+ they use the right new directory. Closes: #362820
+ * dh_installxfonts: also, alias files have moved from /etc/X11/fonts/* to
+ /etc/X11/fonts/X11R7/*, update call to update-fonts-alias and the man page
+ accordingly; packages containing alias files will need to switch to the
+ new directory on their own.
+ * dh_installudev: correct documentation for --name. Closes: #363028
+ * Fix broken directory removal code.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 17 Apr 2006 16:01:11 -0400
debhelper (5.0.30) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 7b3a02b7..f2401f75 100755
--- a/debian/rules
+++ b/debian/rules
@@ -67,7 +67,7 @@ clean:
./run dh_clean *.1 *.7 *-stamp Debian/Debhelper/Dh_Version.pm
po4a --rm-translations --rm-backups man/po4a/po4a.cfg
for lang in $(LANGS); do \
- rmdir man/$$lang; \
+ if [ -e man/$$lang ]; then rmdir man/$$lang; fi; \
done;
test: version test-stamp
diff --git a/dh_installudev b/dh_installudev
index 696543f1..2c6ea418 100755
--- a/dh_installudev
+++ b/dh_installudev
@@ -38,8 +38,7 @@ Do not modify postinst/postrm scripts.
=item B<--name=>I<name>
-Use "name" as the filename the rules file is installed in
-/etc/udev/. When this parameter is used, dh_installudev looks for and
+When this parameter is used, dh_installudev looks for and
installs files named debian/package.name.udev instead of the usual
debian/package.udev.
diff --git a/dh_installxfonts b/dh_installxfonts
index 2bcbe1fa..92379885 100755
--- a/dh_installxfonts
+++ b/dh_installxfonts
@@ -22,8 +22,8 @@ and fonts.scale be rebuilt properly at install time.
Before calling this program, you should have installed any X fonts provided
by your package into the appropriate location in the package build
directory, and if you have fonts.alias or fonts.scale files, you should
-install them into the correct location under etc/X11/fonts in your package
-build directory.
+install them into the correct location under etc/X11/fonts/X11R7 in your
+package build directory.
Your package should depend on xfonts-utils so that the
update-fonts-* commands are available. (This program adds that dependency to
@@ -62,10 +62,10 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my @cmds;
foreach my $f (@fontdirs) {
# This must come before update-fonts-dir.
- push @cmds, "update-fonts-scale $f"
- if -f "$tmp/etc/X11/fonts/$f/$package.scale";
- push @cmds, "update-fonts-dir $f";
- push @cmds, "update-fonts-alias $f"
+ push @cmds, "update-fonts-scale --x11r7-layout $f"
+ if -f "$tmp/etc/X11/fonts/X11R7/$f/$package.scale";
+ push @cmds, "update-fonts-dir --x11r7-layout $f";
+ push @cmds, "update-fonts-alias --x11r7-layout $f"
if -f "$tmp/etc/X11/fonts/$f/$package.alias";
}
diff --git a/man/po4a/po/debhelper.pot b/man/po4a/po/debhelper.pot
index c94d0049..a3b6f213 100644
--- a/man/po4a/po/debhelper.pot
+++ b/man/po4a/po/debhelper.pot
@@ -6,7 +6,7 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2006-04-14 0:39+0200\n"
+"POT-Creation-Date: 2006-04-17 15:59-0400\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"
@@ -3853,8 +3853,8 @@ msgid ""
"Before calling this program, you should have installed any X fonts provided "
"by your package into the appropriate location in the package build "
"directory, and if you have fonts.alias or fonts.scale files, you should "
-"install them into the correct location under etc/X11/fonts in your package "
-"build directory."
+"install them into the correct location under etc/X11/fonts/X11R7 in your "
+"package build directory."
msgstr ""
# type: textblock
diff --git a/man/po4a/po/es.po b/man/po4a/po/es.po
index b969c90e..1749ad9d 100644
--- a/man/po4a/po/es.po
+++ b/man/po4a/po/es.po
@@ -5,7 +5,7 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2006-04-13 10:48+0200\n"
+"POT-Creation-Date: 2006-04-17 15:59-0400\n"
"PO-Revision-Date: 2005-09-18 00:11+0200\n"
"Last-Translator: Rubén Porras Campo <debian-l10n-spanish@lists.debian.org>\n"
"Language-Team: SPANISH <debian-l10n-spanish@lists.debian.org>\n"
@@ -5148,12 +5148,13 @@ msgstr ""
# type: textblock
#: dh_installxfonts:22
+#, fuzzy
msgid ""
"Before calling this program, you should have installed any X fonts provided "
"by your package into the appropriate location in the package build "
"directory, and if you have fonts.alias or fonts.scale files, you should "
-"install them into the correct location under etc/X11/fonts in your package "
-"build directory."
+"install them into the correct location under etc/X11/fonts/X11R7 in your "
+"package build directory."
msgstr ""
"Antes de llamar a este programa, debe tener instalados los tipos de letra "
"para X proporcionados por el paquete en el lugar apropiado del directorio de "
diff --git a/man/po4a/po/fr.po b/man/po4a/po/fr.po
index 96a76b0e..14689dcc 100644
--- a/man/po4a/po/fr.po
+++ b/man/po4a/po/fr.po
@@ -3,7 +3,7 @@
msgid ""
msgstr ""
"Project-Id-Version: debhelper manpages\n"
-"POT-Creation-Date: 2006-04-13 10:48+0200\n"
+"POT-Creation-Date: 2006-04-17 15:59-0400\n"
"PO-Revision-Date: 2006-04-14 11:15+0200\n"
"Last-Translator: Valery Perrin <valery.perrin.debian@free.fr>\n"
"Language-Team: French <debian-l10n-french@lists.debian.org>\n"
@@ -5268,12 +5268,13 @@ msgstr ""
# type: textblock
#: dh_installxfonts:22
+#, fuzzy
msgid ""
"Before calling this program, you should have installed any X fonts provided "
"by your package into the appropriate location in the package build "
"directory, and if you have fonts.alias or fonts.scale files, you should "
-"install them into the correct location under etc/X11/fonts in your package "
-"build directory."
+"install them into the correct location under etc/X11/fonts/X11R7 in your "
+"package build directory."
msgstr ""
"Avant d'exécuter ce programme, il est nécessaire d'avoir installé, dans "
"l'emplacement adéquat du répertoire de construction du paquet, toutes les "