summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_strip3
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 19f3df6e..adc29a2d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.2.15) UNRELEASED; urgency=low
+
+ * dh_strip: Also strip OCaml shared libraries. (Stephane Glondu)
+ Closes: #527272
+
+ -- Joey Hess <joeyh@debian.org> Mon, 18 May 2009 15:42:04 -0400
+
debhelper (7.2.14) unstable; urgency=low
* dh: Avoid writing log after override_dh_clean is run. Closes: #529228
diff --git a/dh_strip b/dh_strip
index 2c667bb7..cfa26653 100755
--- a/dh_strip
+++ b/dh_strip
@@ -115,7 +115,8 @@ sub testfile {
return if $fn=~m/debug\/.*\.so/;
# Does its filename look like a shared library?
- if (m/.*\.so.*?/) {
+ # (*.cmxs are OCaml native code shared libraries)
+ if (m/.*\.(so.*?|cmxs$)/) {
# Ok, do the expensive test.
my $type=get_file_type($_);
if ($type=~m/.*ELF.*shared.*/) {