summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xt/buildsystems/buildsystem_tests6
2 files changed, 6 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index fda83527..cfa66725 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,9 @@
-debhelper (7.3.3) UNRELEASED; urgency=low
+debhelper (7.3.3) experimental; urgency=low
* Add ant buildsystem support. Closes: #537021
+ * Merged debhelper 7.2.22.
- -- Joey Hess <joeyh@debian.org> Tue, 14 Jul 2009 16:35:50 -0400
+ -- Joey Hess <joeyh@debian.org> Tue, 14 Jul 2009 17:16:28 -0400
debhelper (7.3.2) experimental; urgency=low
diff --git a/t/buildsystems/buildsystem_tests b/t/buildsystems/buildsystem_tests
index 7d383157..8f7a275a 100755
--- a/t/buildsystems/buildsystem_tests
+++ b/t/buildsystems/buildsystem_tests
@@ -1,6 +1,6 @@
#!/usr/bin/perl
-use Test::More tests => 227;
+use Test::More tests => 228;
use strict;
use warnings;
@@ -19,7 +19,6 @@ use_ok( 'Debian::Debhelper::Dh_Buildsystems' );
my $TOPDIR = "../..";
my @STEPS = qw(configure build test install clean);
-my @BUILDSYSTEMS = qw(autoconf perl_makemaker makefile python_distutils perl_build cmake);
my $BS_CLASS = 'Debian::Debhelper::Buildsystem';
my ($bs, @bs, %bs);
@@ -188,7 +187,8 @@ test_buildsystem_paths_api($bs, "builddir=../bld/dir, sourcedir=autoconf", \%tmp
### Test if all buildsystems can be loaded
@bs = load_all_buildsystems([ $INC[0] ]);
@tmp = map { $_->NAME() } @bs;
-is_deeply( \@tmp, \@BUILDSYSTEMS, "load_all_buildsystems() loads all built-in buildsystems" );
+ok(@Debian::Debhelper::Dh_Buildsystems::BUILDSYSTEMS >= 1, "some build systems are built in" );
+is_deeply( \@tmp, \@Debian::Debhelper::Dh_Buildsystems::BUILDSYSTEMS, "load_all_buildsystems() loads all built-in buildsystems" );
### Test check_auto_buildable() of each buildsystem
sub test_check_auto_buildable {