summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm10
-rw-r--r--debian/changelog8
2 files changed, 13 insertions, 5 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index 671bca57..bfe1c08e 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -43,12 +43,12 @@ sub configure {
my @flags;
$ENV{PERL_MM_USE_DEFAULT}=1;
if ($ENV{CFLAGS} && ! compat(8)) {
- push @flags, "config=optimize=$ENV{CFLAGS} $ENV{CPPFLAGS}";
+ push @flags, "--config", "optimize=$ENV{CFLAGS} $ENV{CPPFLAGS}";
}
if ($ENV{LDFLAGS} && ! compat(8)) {
- push @flags, "config=ld=$Config{ld} $ENV{CFLAGS} $ENV{LDFLAGS}";
+ push @flags, "--config", "ld=$Config{ld} $ENV{CFLAGS} $ENV{LDFLAGS}";
}
- $this->do_perl("Build.PL", "installdirs=vendor", @flags, @_);
+ $this->do_perl("Build.PL", "--installdirs", "vendor", @flags, @_);
}
sub build {
@@ -64,13 +64,13 @@ sub test {
sub install {
my $this=shift;
my $destdir=shift;
- $this->do_perl("Build", "install", "destdir=$destdir", "create_packlist=0", @_);
+ $this->do_perl("Build", "install", "--destdir", "$destdir", "--create_packlist", 0, @_);
}
sub clean {
my $this=shift;
if (-e $this->get_sourcepath("Build")) {
- $this->do_perl("Build", "--allow_mb_mismatch", 1, "distclean", @_);
+ $this->do_perl("Build", "distclean", "--allow_mb_mismatch", 1, @_);
}
}
diff --git a/debian/changelog b/debian/changelog
index 716598a5..24ec5c41 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (9.20130627) UNRELEASED; urgency=low
+
+ * perl_build: Use -- long option names, for compatability with
+ Module::Build::Tiny. Closes: #714544
+ (Thanks, gregor herrmann)
+
+ -- Joey Hess <joeyh@debian.org> Sun, 30 Jun 2013 13:09:28 -0400
+
debhelper (9.20130626) unstable; urgency=low
* dh_strip: Run readelf in C locale. Closes: #714187