summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm6
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_installdebconf13
-rwxr-xr-xdh_installman2
4 files changed, 24 insertions, 6 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 0aa883b1..0ed7c477 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -11,9 +11,9 @@ use Exporter;
use vars qw(@ISA @EXPORT %dh);
@ISA=qw(Exporter);
@EXPORT=qw(&init &doit &complex_doit &verbose_print &error &warning &tmpdir
- &pkgfile &pkgext &isnative &autoscript &filearray &GetPackages
- &basename &dirname &xargs %dh &compat &addsubstvar &delsubstvar
- &excludefile);
+ &pkgfile &pkgext &isnative &autoscript &filearray &filedoublearray
+ &GetPackages &basename &dirname &xargs %dh &compat &addsubstvar
+ &delsubstvar &excludefile);
my $max_compat=4;
diff --git a/debian/changelog b/debian/changelog
index 342f4c76..dfb817c5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (4.0.1) unstable; urgency=low
+
+ * dh_installdebconf: allow parameters after -- to go to
+ debconf-mergetemplate.
+ * dh_installman: don't whine about zero-length man pages in .so conversion.
+ * Forgot to export filedoublearray, Closes: #142784
+
+ -- Joey Hess <joeyh@debian.org> Fri, 12 Apr 2002 23:22:15 -0400
+
debhelper (4.0.0) unstable; urgency=low
* dh_movefiles has long been a sore point in debhelper. Inherited
diff --git a/dh_installdebconf b/dh_installdebconf
index 9dc13bbf..2b6bdc70 100755
--- a/dh_installdebconf
+++ b/dh_installdebconf
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-B<dh_installdebconf> [S<I<debhelper options>>] [B<-n>]
+B<dh_installdebconf> [S<I<debhelper options>>] [B<-n>] [S<B<--> I<params>>]
=head1 DESCRIPTION
@@ -51,12 +51,21 @@ debian/package.templates.de is merged with debian/package.templates.
Do not modify postrm script.
+=item B<--> I<params>
+
+Pass the params to debconf-mergetemplate.
+
=back
=cut
init();
+my @extraparams;
+if (defined($dh{U_PARAMS})) {
+ @extraparams=@{$dh{U_PARAMS}};
+}
+
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
my $config=pkgfile($package,"config");
@@ -75,7 +84,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Are there translated templates too?
my @trans=(glob("$templates.??"), glob("$templates.??_??"));
if (@trans) {
- complex_doit("debconf-mergetemplate @trans $templates > $tmp/DEBIAN/templates");
+ complex_doit("debconf-mergetemplate @extraparams @trans $templates > $tmp/DEBIAN/templates");
chmod 0644, "$tmp/DEBIAN/templates";
chown 0, 0, "$tmp/DEBIAN/templates";
}
diff --git a/dh_installman b/dh_installman
index 30fde7e2..cc94843e 100755
--- a/dh_installman
+++ b/dh_installman
@@ -170,7 +170,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
sub find_so_man {
# The -s test is becuase a .so file tends to be small. We don't want
# to open every man page. 1024 is arbitrary.
- if (! -f $_ || -s $_ > 1024) {
+ if (! -f $_ || -s $_ > 1024 || -s == 0) {
return;
}