summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-icons14
-rw-r--r--autoscripts/postrm-icons30
-rw-r--r--debian/changelog7
3 files changed, 29 insertions, 22 deletions
diff --git a/autoscripts/postinst-icons b/autoscripts/postinst-icons
index 3c018b35..d35f30c0 100644
--- a/autoscripts/postinst-icons
+++ b/autoscripts/postinst-icons
@@ -1,7 +1,7 @@
-if which gtk-update-icon-cache >/dev/null 2>&1; then
- for dir in #DIRLIST#; do
- if [ -f "$dir"/icon-theme.cache ]; then
- gtk-update-icon-cache --force --quiet "$dir"
- fi
- done
-fi
+if which gtk-update-icon-cache >/dev/null 2>&1; then
+ for dir in #DIRLIST#; do
+ if [ -f "$dir"/icon-theme.cache ]; then
+ gtk-update-icon-cache --force --quiet "$dir"
+ fi
+ done
+fi
diff --git a/autoscripts/postrm-icons b/autoscripts/postrm-icons
index 3765560c..87fd790b 100644
--- a/autoscripts/postrm-icons
+++ b/autoscripts/postrm-icons
@@ -1,15 +1,15 @@
-if [ "$1" = "remove" ]; then
- for dir in #DIRLIST#; do
- if [ -d "$dir" ]; then
- if [ -f "$dir"/index.theme ] && \
- [ -f "$dir"/icon-theme.cache ] && \
- which gtk-update-icon-cache >/dev/null 2>&1
- then
- gtk-update-icon-cache --force --quiet "$dir"
- else
- rm -f "$dir"/icon-theme.cache
- rmdir -p --ignore-fail-on-non-empty "$dir"
- fi
- fi
- done
-fi
+if [ "$1" = "remove" ]; then
+ for dir in #DIRLIST#; do
+ if [ -d "$dir" ]; then
+ if [ -f "$dir"/index.theme ] && \
+ [ -f "$dir"/icon-theme.cache ] && \
+ which gtk-update-icon-cache >/dev/null 2>&1
+ then
+ gtk-update-icon-cache --force --quiet "$dir"
+ else
+ rm -f "$dir"/icon-theme.cache
+ rmdir -p --ignore-fail-on-non-empty "$dir"
+ fi
+ fi
+ done
+fi
diff --git a/debian/changelog b/debian/changelog
index 1cc9e0d6..0ac6f688 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (5.0.52) UNRELEASED; urgency=low
+
+ * Remove DOS line endings from dh_icons scriptlets. Thanks, Daniel Holbach.
+ Closes: #432321
+
+ -- Joey Hess <joeyh@debian.org> Mon, 09 Jul 2007 11:24:59 -0400
+
debhelper (5.0.51) unstable; urgency=low
* dh_icons: New program to update Freedesktop icon caches. Thanks