summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-xaw8
-rw-r--r--autoscripts/postrm-xaw3
-rw-r--r--autoscripts/prerm-xaw5
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules2
-rwxr-xr-xdh_installdocs23
-rwxr-xr-xdh_installxaw116
-rw-r--r--doc/README1
-rw-r--r--doc/TODO3
9 files changed, 18 insertions, 151 deletions
diff --git a/autoscripts/postinst-xaw b/autoscripts/postinst-xaw
deleted file mode 100644
index f7703dcf..00000000
--- a/autoscripts/postinst-xaw
+++ /dev/null
@@ -1,8 +0,0 @@
-if [ "$1" = "configure" ]; then
- if which update-xaw-wrappers >/dev/null 2>&1; then
- update-xaw-wrappers
- fi
- for opts in #OPTS#; do
- update-alternatives --quiet --install $opts 25
- done
-fi
diff --git a/autoscripts/postrm-xaw b/autoscripts/postrm-xaw
deleted file mode 100644
index 61bd3c9f..00000000
--- a/autoscripts/postrm-xaw
+++ /dev/null
@@ -1,3 +0,0 @@
-if which update-xaw-wrappers >/dev/null 2>&1; then
- update-xaw-wrappers
-fi
diff --git a/autoscripts/prerm-xaw b/autoscripts/prerm-xaw
deleted file mode 100644
index 98837f82..00000000
--- a/autoscripts/prerm-xaw
+++ /dev/null
@@ -1,5 +0,0 @@
-if [ "$1" = "remove" ]; then
- for opts in #OPTS#; do
- update-alternatives --quiet --remove $opts
- done
-fi
diff --git a/debian/changelog b/debian/changelog
index 593d2c49..d7f088a3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.1.0) unstable; urgency=low
+
+ * Remove /usr/doc manglement code from postinst and prerm.
+ Do not use this verion of debhelper for woody backports!
+ * Removed dh_installxaw.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 21 Jul 2002 15:26:10 -0400
+
debhelper (4.0.19) unstable; urgency=low
* Make dh_installchangelogs install debian/NEWS files as well, as
diff --git a/debian/rules b/debian/rules
index af24fb5f..a3ff112e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -72,7 +72,7 @@ binary-indep: build
./dh_install -X .1 dh_* usr/bin
./dh_install Debian/Debhelper/*.pm $(PERLLIBDIR)/Debian/Debhelper/
./dh_install autoscripts usr/share/debhelper
- ./dh_installdocs doc
+ ./dh_installdocs doc/*
./dh_installexamples examples/*
./dh_installman *.1
./dh_installchangelogs
diff --git a/dh_installdocs b/dh_installdocs
index 7bfe8ff1..7a8fc461 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -39,11 +39,6 @@ debian/package.TODO can be used to specify files for subpackages.
Files named debian/package.docs can list other files to be installed.
-This program will automatically generate postinst and prerm commands to
-maintain a compatibility symlink, /usr/doc/package, to the documentation in
-/usr/share/doc/package. See L<dh_installdeb(1)> for an explanation of how
-this works.
-
Files named debian/package.doc-base, will be installed as doc-base control
files, and will make this program automatically generate the postinst and
prerm commands needed to interface with the doc-base package. Note that the
@@ -174,15 +169,15 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
}
- # Add in the /usr/doc compatibility symlinks code.
- if (! $dh{NOSCRIPTS}) {
- autoscript($package,"postinst","postinst-doc",
- "s/#PACKAGE#/$package/g",
- );
- autoscript($package,"prerm","prerm-doc",
- "s/#PACKAGE#/$package/g",
- );
- }
+# # Add in the /usr/doc compatibility symlinks code.
+# if (! $dh{NOSCRIPTS}) {
+# autoscript($package,"postinst","postinst-doc",
+# "s/#PACKAGE#/$package/g",
+# );
+# autoscript($package,"prerm","prerm-doc",
+# "s/#PACKAGE#/$package/g",
+# );
+# }
# Handle doc-base files. There are two filename formats, the usual
# plus an extended format (debian/package.*).
diff --git a/dh_installxaw b/dh_installxaw
deleted file mode 100755
index 17321834..00000000
--- a/dh_installxaw
+++ /dev/null
@@ -1,116 +0,0 @@
-#!/usr/bin/perl -w
-
-=head1 NAME
-
-dh_installxaw - install xaw wrappers config files into package build directories
-
-=cut
-
-use strict;
-use Debian::Debhelper::Dh_Lib;
-
-=head1 SYNOPSIS
-
-B<dh_installxaw> [S<I<debhelper options>>] [B<-n>]
-
-=head1 DESCRIPTION
-
-Warning: The xaw-wrappers package has been removed from debian, and so this
-program is deprecated, and due to be removed soon.
-
-dh_installxaw is a debhelper program that is responsible for installing
-xaw wrappers config files into package build directories.
-
-It also automatically generates the postinst, prerm, and postrm commands
-needed to interface with the debian xaw-wrappers package. See
-L<dh_installdeb(1)> for an explanation of how this works.
-
-If a file named debian/package.xaw exists, then it is installed into
-usr/lib/xaw-wrappers/config/package in the package build directory.
-
-=head1 OPTIONS
-
-=over 4
-
-=item B<-n>, B<--noscripts>
-
-Do not modify postinst/prerm/postrm scripts.
-
-=back
-
-=head1 NOTES
-
-Note that this command is not idempotent. "dh_clean -k" should be called
-between invocations of this command. Otherwise, it may cause multiple
-instances of the same text to be added to maintainer scripts.
-
-=cut
-
-init();
-
-warning("The xaw-wrappers package has been removed from debian, and so this program is deprecated, and due to be removed soon.");
-
-foreach my $package (@{$dh{DOPACKAGES}}) {
- my $tmp=tmpdir($package);
- my $xaw=pkgfile($package,'xaw');
-
- if ($xaw ne '') {
- if (! -d "$tmp/usr/share/xaw-wrappers/config") {
- doit("install","-d","$tmp/usr/share/xaw-wrappers/config");
- }
- doit("install","-p","-m644",$xaw,
- "$tmp/usr/share/xaw-wrappers/config/$package");
-
- if (! $dh{NOSCRIPTS}) {
- # Parse the xaw conf file to figure out what programs
- # and link names are present in it. Have to pass
- # those into the scripts.
- my %data;
- my $install_opts='';
- my $remove_opts='';
- my $stanza='';
-
- open (IN,$xaw);
- while (<IN>) {
- chomp;
- s/\s+/ /g;
- if (/^#/ eq '') {
- if (/(.*?):\s?(.*)/) {
- $data{lc($1)}=$2;
- $stanza=1;
- }
- elsif ($stanza) {
- $install_opts.="'$data{program} $data{'link-name'} $data{wrapped}' ";
- $remove_opts.="'$data{'link-name'} $data{wrapped}' ";
- undef %data;
- $stanza='';
- }
- }
- }
- close IN;
-
- if ($stanza) {
- $install_opts.="'$data{program} $data{'link-name'} $data{wrapped}'";
- $remove_opts.="'$data{'link-name'} $data{wrapped}'";
- }
-
- autoscript($package,"postinst","postinst-xaw",
- "s:#OPTS#:$install_opts:");
- autoscript($package,"prerm","prerm-xaw",
- "s:#OPTS#:$remove_opts:");
- autoscript($package,"postrm","postrm-xaw");
- }
- }
-}
-
-=head1 SEE ALSO
-
-L<debhelper(1)>
-
-This program is a part of debhelper.
-
-=head1 AUTHOR
-
-Joey Hess <joeyh@debian.org>
-
-=cut
diff --git a/doc/README b/doc/README
index 6ae07976..a257052b 100644
--- a/doc/README
+++ b/doc/README
@@ -1,2 +1 @@
Please see the debhelper(1) man page for documentation.
-
diff --git a/doc/TODO b/doc/TODO
index 71534ea2..f0d31c87 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -59,7 +59,4 @@ Deprecated:
* dh_installmanpages. Only mildly deprecated right now. Once dh_installman
catches on, make it emit a warning, and then wait for it to go away.
* dh_testversion. Remove as soon as nothing uses it.
-* dh_installxaw. xaw replacments are dying, nothing uses it validly (bugs
- filed on the few packages that use it by accident). Remove as soon as
- nothing uses it, or by april 2002.
* dh_movefiles. I won't hold my breath.