summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdh_auto_configure3
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 22bc55ba..1f5cff0b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,9 @@ debhelper (7.2.11) UNRELEASED; urgency=low
* dh: Support --with addon,addon,...
Closes: #528178
+ * dh_auto_configure: Add --skipdeps when running Makefile.PL,
+ to prevent Module::Install from trying to download dependencies.
+ Closes: #528235
-- Joey Hess <joeyh@debian.org> Mon, 11 May 2009 14:50:33 -0400
diff --git a/dh_auto_configure b/dh_auto_configure
index 2dc3eb32..a320df95 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -91,7 +91,8 @@ elsif (-e "Makefile.PL") {
# If set to a true value then MakeMaker's prompt function will
# # always return the default without waiting for user input.
$ENV{PERL_MM_USE_DEFAULT}=1;
- doit("perl", "Makefile.PL", "INSTALLDIRS=vendor", "create_packlist=0", @{$dh{U_PARAMS}});
+ doit("perl", "Makefile.PL", "INSTALLDIRS=vendor",
+ "create_packlist=0", "--skipdeps", @{$dh{U_PARAMS}});
}
elsif (-e "Build.PL") {
$ENV{PERL_MM_USE_DEFAULT}=1; # Module::Build can also use this.