summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm3
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installman2
3 files changed, 11 insertions, 1 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index a21db5da..ea4046a3 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -19,6 +19,9 @@ my $max_compat=4;
sub init {
# If DH_OPTIONS is set, prepend it @ARGV.
if (defined($ENV{DH_OPTIONS})) {
+ # Ignore leading/trailing whitespace.
+ $ENV{DH_OPTIONS}=~s/^\s+//;
+ $ENV{DH_OPTIONS}=~s/\s+$//;
unshift @ARGV,split(/\s+/,$ENV{DH_OPTIONS});
}
diff --git a/debian/changelog b/debian/changelog
index 6fb86b43..44990371 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.4.6) unstable; urgency=low
+
+ * Typo, Closes: #132454
+ * Ignore leading/trailing whitespace in DH_OPTIONS, Closes: #132645
+
+ -- Joey Hess <joeyh@debian.org> Tue, 5 Feb 2002 17:33:57 -0500
+
debhelper (3.4.5) unstable; urgency=low
* dh_installxfonts: separate multiple commands with \n so sed doesn't get
diff --git a/dh_installman b/dh_installman
index d61a2fa3..e558f266 100755
--- a/dh_installman
+++ b/dh_installman
@@ -24,7 +24,7 @@ extension. It also supports translated man pages, by looking for extensions
like .ll.8 and .ll_LL.8
If dh_installman seems to install a man page into the wrong section or with
-the wrong extension, this is because the man page has thw wrong section
+the wrong extension, this is because the man page has the wrong section
listed in its .TH line. Edit the man page and correct the section, and
dh_installman will follow suit. See to L<man(7)> for details about the .TH
section.