summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdh_installdirs60
-rw-r--r--dh_installdirs.145
-rwxr-xr-xdh_installdocs100
-rw-r--r--dh_installdocs.188
-rwxr-xr-xdh_installemacsen73
-rw-r--r--dh_installemacsen.152
6 files changed, 223 insertions, 195 deletions
diff --git a/dh_installdirs b/dh_installdirs
index 340c966e..e0aae209 100755
--- a/dh_installdirs
+++ b/dh_installdirs
@@ -1,9 +1,52 @@
#!/usr/bin/perl -w
-#
-# Reads debian/dirs, creates the directories listed there
+
+=head1 NAME
+
+dh_installdirs - create subdirectories in package build directories
+
+=cut
use strict;
use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+ dh_installdirs [debhelper options] [-A] [dir ...]
+
+=head1 DESCRIPTION
+
+dh_installdirs is a debhelper program that is responsible for creating
+subdirectories in package build directories.
+
+Any directory names specified as parameters will be created in the package
+build directory of the first package dh_installdirs is told to act on. By
+default, this is the first binary package in debian/control, but if you use
+-p, -i, or -a flags, it will be the first package specified by those flags.
+
+A file named debian/package.dirs can list other directories to be created.
+Separate the directory names with whitespace.
+
+Be sure to only use directory names relative to the package build
+directory. Ie, "/usr/bin" should not be used, use "usr/bin" instead.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-A>, B<--all>
+
+Create any directories specified by command line parameters in ALL packages
+acted on, not just the first.
+
+=item I<dir ...>
+
+Create these directories in the package build directory of the first
+package acted on. (Or in all packages if -A is specified.)
+
+=back
+
+=cut
+
init();
foreach my $package (@{$dh{DOPACKAGES}}) {
@@ -40,3 +83,16 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
doit("install","-d",@dirs);
}
}
+
+=head1 SEE ALSO
+
+L<debhelper(1)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
+
diff --git a/dh_installdirs.1 b/dh_installdirs.1
deleted file mode 100644
index c2ce94cf..00000000
--- a/dh_installdirs.1
+++ /dev/null
@@ -1,45 +0,0 @@
-.TH DH_INSTALLDIRS 1 "" "Debhelper Commands" "Debhelper Commands"
-.SH NAME
-dh_installdirs \- create subdirectories in package build directories
-.SH SYNOPSIS
-.B dh_installdirs
-.I "[debhelper options] [-A] [dir ...]"
-.SH "DESCRIPTION"
-dh_installdirs is a debhelper program that is responsible for creating
-subdirectories in package build directories.
-.P
-Any directory names specified as parameters will be created in the package
-build directory of the first package dh_installdirs is told to act on. By
-default, this is the first binary package in debian/control, but if you use
--p, -i, or -a flags, it will be the first package specified by those flags.
-.P
-A file named debian/package.dirs can list other directories to be created.
-Separate the directory names with whitespace.
-.P
-Be sure to only use directory names relative to the package build
-directory. Ie, "/usr/bin" should not be used, use "usr/bin" instead.
-.SH OPTIONS
-.TP
-.B debhelper options
-See
-.BR debhelper (1)
-for a list of options common to all debhelper commands.
-.TP
-.B \-A, \--all
-Create any directories specified by command line parameters in ALL packages
-acted on, not just the first.
-.TP
-.B dir ...
-Create these directories in the package build directory of the first package
-acted on. (Or in all packages if -A is specified.)
-.SH ENVIRONMENT
-See
-.BR debhelper (1)
-for a list of environment variables that affect all debhelper commands.
-.SH "SEE ALSO"
-.BR debhelper (1)
-.SH BUGS
-It's impossible to specify filenames with spaces or other whitespace in them
-in debian/package.dirs file. This is more a historical design flaw than a bug.
-.SH AUTHOR
-Joey Hess <joeyh@debian.org>
diff --git a/dh_installdocs b/dh_installdocs
index 7cadc5e8..00ea5898 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -1,12 +1,90 @@
#!/usr/bin/perl -w
-#
-# Reads debian/docs, installs all files listed there into
-# /usr/share/doc/$package
-# Also installs the debian/copyright and debian/README.debian and debian/TODO
-# and handles debian/doc-base.
+
+=head1 NAME
+
+dh_installdocs - install documentation into package build directories
+
+=cut
use strict;
use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+ dh_installdocs debhelper options] [-A] [-n] [file ...]
+
+=head1 DESCRIPTION
+
+dh_installdocs is a debhelper program that is responsible for installing
+documentation into usr/share/doc/package in package build directories.
+
+dh_installdocs automatically installs debian/copyright if it exists. If
+dh_installdocs is acting on multiple packages, debian/copyright files will be
+installed into all packages. However, if you need to have seperate copyright
+files for different binary packages, you can use files named
+debian/package.copyright.
+
+Any filenames specified as parameters will be installed into the first
+package dh_installdocs is told to act on. By default, this is the first
+binary package in debian/control, but if you use -p, -i, or -a flags, it
+will be the first package specified by those flags.
+
+Also, debian/README.Debian (or debian/README.debian) and debian/TODO, if
+they exist, will be installed into the first binary package listed in
+debian/control, if dh_installdocs is acting on that package. Note that
+debian/TODO will be installed named TODO.Debian, if the package is not a
+debian native package. Also note that README.debian is installed as
+README.Debian, for consitency. Note that debian/package.README.Debian and
+debian/package.TODO can be used to specify files for subpackages.
+
+Files named debian/package.docs can list other files to be installed.
+
+This program will automatically generate postinst and prerm commands to
+maintain a compatibility symlink, /usr/doc/package, to the documentation in
+/usr/share/doc/package. See L<dh_installdeb(1)> for an explanation of how
+this works.
+
+Files named debian/package.doc-base, will be installed as doc-base control
+files, and will make this program automatically generate the postinst and
+prerm commands needed to interface with the doc-base package. Note that the
+doc-id will be determined from the "Document:" entry in the
+doc-base control file in question.
+
+If your package needs to register more than one document, you need multiple
+files. To accomplish this, you can use files named debian/package.doc-base.*
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-A>, B<--all>
+
+Install all files specified by command line parameters in ALL packages
+acted on.
+
+=item B<-n>, B<--noscripts>
+
+Do not modify postinst/prerm scripts.
+
+=item I<file ...>
+
+Install these files as documentation into the first package acted on. (Or
+in all packages if -A is specified).
+
+=back
+
+=head1 NOTES
+
+Note that dh_installdocs will happily copy entire directory hierarchies if
+you ask it to (it uses cp -a internally). If it is asked to install a
+directory, it will install the complete contents of the directory.
+
+Note that this command is not idempotent. "dh_clean -k" should be called
+between invocations of this command. Otherwise, it may cause multiple
+instances of the same text to be added to maintainer scripts.
+
+=cut
+
init();
foreach my $package (@{$dh{DOPACKAGES}}) {
@@ -128,3 +206,15 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
}
}
+
+=head1 SEE ALSO
+
+L<debhelper(1)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
diff --git a/dh_installdocs.1 b/dh_installdocs.1
deleted file mode 100644
index 6df294cb..00000000
--- a/dh_installdocs.1
+++ /dev/null
@@ -1,88 +0,0 @@
-.TH DH_INSTALLDOCS 1 "" "Debhelper Commands" "Debhelper Commands"
-.SH NAME
-dh_installdocs \- install documentation into package build directories
-.SH SYNOPSIS
-.B dh_installdocs
-.I "[debhelper options] [-A] [-n] [file ...]"
-.SH "DESCRIPTION"
-dh_installdocs is a debhelper program that is responsible for installing
-documentation into usr/share/doc/package in package build directories.
-.P
-dh_installdocs automatically installs debian/copyright if it exists. If
-dh_installdocs is acting on multiple packages, debian/copyright files will be
-installed into all packages. However, if you need to have seperate copyright
-files for different binary packages, you can use files named
-debian/package.copyright.
-.P
-Any filenames specified as parameters will be installed into the first
-package dh_installdocs is told to act on. By default, this is the first
-binary package in debian/control, but if you use -p, -i, or -a flags, it
-will be the first package specified by those flags.
-.P
-Also, debian/README.Debian (or debian/README.debian) and debian/TODO, if
-they exist, will be installed into the first binary package listed in
-debian/control, if dh_installdocs is acting on that package. Note that
-debian/TODO will be installed named TODO.Debian, if the package is not a
-debian native package. Also note that README.debian is installed as
-README.Debian, for consitency. Note that debian/package.README.Debian and
-debian/package.TODO can be used to specify files for subpackages.
-.P
-Files named debian/package.docs can list other files to be installed.
-.P
-This program will automatically generate postinst and prerm commands to
-maintain a compatibility symlink, /usr/doc/package, to the documentation in
-/usr/share/doc/package. See
-.BR dh_installdeb (1)
-for an explanation of how this works.
-.P
-Files named debian/package.doc-base, will be installed as doc-base control
-files, and will make this program automatically generate the postinst and
-prerm commands needed to interface with the doc-base package. See
-.BR dh_installdeb (1)
-for an explanation of how this works.
-Note that the doc-id will be determined from the "Document:" entry in the
-doc-base control file in question.
-.PP
-If your package needs to register more
-than one document, you need multiple files. To accomplish this, you can use
-files named debian/package.doc-base.*
-.SH OPTIONS
-.TP
-.B debhelper options
-See
-.BR debhelper (1)
-for a list of options common to all debhelper commands.
-.TP
-.B \-A, \--all
-Install all files specified by command line parameters in ALL packages
-acted on.
-.TP
-.B \-n, \--noscripts
-Do not modify postinst/prerm scripts.
-.TP
-.B file ...
-Install these files as documentation into the first package acted on. (Or in
-all packages if -A is specified).
-.SH NOTES
-Note that dh_installdocs will happily copy entire directory hierarchies if
-you ask it to (it uses cp -a internally). If it is asked to install a
-directory, it will install the complete contents of the directory.
-.P
-Note that this command is not idempotent. "dh_clean -k" should be called
-between invocations of this command. Otherwise, it may cause multiple
-instances of the same text to be added to maintainer scripts.
-.SH ENVIRONMENT
-See
-.BR debhelper (1)
-for a list of environment variables that affect all debhelper commands.
-.SH "SEE ALSO"
-.BR debhelper (1)
-.TP
-.BR install-docs (8)
-.SH BUGS
-It's impossible to specify filenames with spaces or other whitespace in them
-in debian/package.docs file. This is more a historical design flaw than a bug.
-.SH "CONFORMS TO"
-Debian policy, version 3.0.1
-.SH AUTHOR
-Joey Hess <joeyh@debian.org>
diff --git a/dh_installemacsen b/dh_installemacsen
index a0b82781..b6b511ad 100755
--- a/dh_installemacsen
+++ b/dh_installemacsen
@@ -1,9 +1,64 @@
#!/usr/bin/perl -w
-#
-# Registration with emacsen-common.
+
+=head1 NAME
+
+dh_installemacsen - register an emacs add on package
+
+=cut
use strict;
use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+ dh_installemacsen [debhelper options] [-n] [--priority=n]
+ [--flavor=foo]
+
+=head1 DESCRIPTION
+
+dh_installemacsen is a debhelper program that is responsible for installing
+files used by the debian emacsen-common package into package build
+directories.
+
+It also automatically generates the postinst and prerm commands needed to
+register a package as an emacs add on package. See L<dh_installdeb(1)>
+for an explanation of how this works.
+
+If a file named debian/package.emacsen-install exists, then it is installed
+into
+usr/lib/emacsen-common/packages/install/package in the package build
+directory. Similarly, debian/package.emacsen-remove is installed into
+usr/lib/emacsen-common/packages/remove/package . And similarly,
+debian/package.emacsen-startup is installed into
+etc/emacs/site-start.d/50<package>.el (by default).
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-n>, B<--noscripts>
+
+Do not modify postinst/prerm scripts.
+
+=item B<--priority=>I<n>
+
+Sets the priority number of a site-start.d file. Default is 50.
+
+=item B<--flavor=>I<foo>
+
+Sets the flavor a site-start.d file will be installed in. Default is
+"emacs", alternatives include "xemacs" and "emacs20".
+
+=back
+
+=head1 NOTES
+
+Note that this command is not idempotent. "dh_clean -k" should be called
+between invocations of this command. Otherwise, it may cause multiple
+instances of the same text to be added to maintainer scripts.
+
+=cut
+
init();
if (! defined $dh{PRIORITY}) {
@@ -49,4 +104,16 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
"s/#PACKAGE#/$package/");
}
}
-}
+}
+
+=head1 SEE ALSO
+
+L<debhelper(1)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
diff --git a/dh_installemacsen.1 b/dh_installemacsen.1
deleted file mode 100644
index 963e2268..00000000
--- a/dh_installemacsen.1
+++ /dev/null
@@ -1,52 +0,0 @@
-.TH DH_INSTALLEMACSEN 1 "" "Debhelper Commands" "Debhelper Commands"
-.SH NAME
-dh_installemacsen \- register an emacs add on package
-.SH SYNOPSIS
-.B dh_installemacsen
-.I "[debhelper options] [-n] [--priority=n] [--flavor=foo]"
-.SH "DESCRIPTION"
-dh_installemacsen is a debhelper program that is responsible for installing
-files used by the debian emacsen-common package into package build directories.
-.P
-It also automatically generates the postinst and prerm commands needed to
-register a package as an emacs add on package. See
-.BR dh_installdeb (1)
-for an explanation of how this works.
-.P
-If a file named debian/package.emacsen-install exists, then it is installed into
-usr/lib/emacsen-common/packages/install/package in the package build
-directory. Similarly, debian/package.emacsen-remove is installed into
-usr/lib/emacsen-common/packages/remove/package . And similarly,
-debian/package.emacsen-startup is installed into
-etc/emacs/site-start.d/50<package>.el (by default).
-.SH OPTIONS
-.TP
-.B debhelper options
-See
-.BR debhelper (1)
-for a list of options common to all debhelper commands.
-.TP
-.B \-n, \--noscripts
-Do not modify postinst/prerm scripts.
-.TP
-.B \--priority=n
-Sets the priority number of a site-start.d file. Default is 50.
-.TP
-.B \--flavor=foo
-Sets the flavor a site-start.d file will be installed in. Default is
-"emacs", alternatives include "xemacs" and "emacs20".
-.SH ENVIRONMENT
-See
-.BR debhelper (1)
-for a list of environment variables that affect all debhelper commands.
-.SH NOTES
-Note that this command is not idempotent. "dh_clean -k" should be called
-between invocations of this command. Otherwise, it may cause multiple
-instances of the same text to be added to maintainer scripts.
-.SH "SEE ALSO"
-.TP
-.BR debhelper (1)
-.TP
-.BR /usr/doc/emacsen-common/debian-emacs-policy.gz
-.SH AUTHOR
-Joey Hess <joeyh@debian.org>