summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xdh_md5sums4
2 files changed, 4 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 42615897..092fb6ad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,12 +1,11 @@
-debhelper (4.2.33) UNRELEASED; urgency=low
+debhelper (4.2.33) unstable; urgency=low
* Update Spanish translation of dh_clean man page. Closes: #303052
* dh_installmodules autoscripts: Now that return code 3 is allocated by
update-modules to indicate /etc/modules.conf is not automatically
generated, we can ignore that return code since it's not a condition that
should fail an installation. Closes: #165400
- * dh_md5sums: Don't pass "." to find, so results don't have ./ prepended,
- which broke exclusion of conffiles. Thanks, Damir Dzeko
+ * dh_md5sums: Fix exclusion of conffiles. Thanks, Damir Dzeko
(note: this was broken in version 4.1.22)
-- Joey Hess <joeyh@debian.org> Sat, 9 Apr 2005 17:27:12 -0400
diff --git a/dh_md5sums b/dh_md5sums
index 91c217e2..8fd8b2eb 100755
--- a/dh_md5sums
+++ b/dh_md5sums
@@ -62,7 +62,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
while (<CONFF>) {
chomp;
s/^\///;
- $exclude.="! -path \"$_\" ";
+ $exclude.="! -path \"./$_\" ";
}
close CONFF;
}
@@ -73,7 +73,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
my $olddir=getcwd();
- complex_doit("cd $tmp >/dev/null ; find -type f $exclude ! -regex '.*/DEBIAN/.*' -printf '%P\\0' | xargs -r0 md5sum > DEBIAN/md5sums ; cd '$olddir' >/dev/null");
+ complex_doit("cd $tmp >/dev/null ; find . -type f $exclude ! -regex '.*/DEBIAN/.*' -printf '%P\\0' | xargs -r0 md5sum > DEBIAN/md5sums ; cd '$olddir' >/dev/null");
# If the file's empty, no reason to waste inodes on it.
if (-z "$tmp/DEBIAN/md5sums") {
doit("rm","-f","$tmp/DEBIAN/md5sums");