summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdh24
-rw-r--r--doc/PROGRAMMING33
3 files changed, 24 insertions, 34 deletions
diff --git a/debian/changelog b/debian/changelog
index 5321bdba..afe27c11 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ debhelper (7.2.8) UNRELEASED; urgency=low
* dh_desktop: Now a deprecated no-op, since desktop-file-utils
uses triggers. Closes: #523474
(also Closes: #521960, #407701 as no longer applicable)
+ * Move dh sequence documentation to PROGRAMMING.
-- Joey Hess <joeyh@debian.org> Tue, 31 Mar 2009 14:07:13 -0400
diff --git a/dh b/dh
index 6ac495a2..5ad0ecc9 100755
--- a/dh
+++ b/dh
@@ -50,8 +50,8 @@ you should Build-Depend on debhelper 7.0.50 or above.)
Add the debhelper commands specified by the given addon to appropriate places
in the sequence of commands that is run. This option can be repeated more
than once, and is used when there is a third-party package that provides
-debhelper commands. See "SEQUENCE ADDONS" below for documentation about what
-such packages should do to be supported by --with.
+debhelper commands. See the PROGRAMMING file for documentation about
+the sequence addon interface.
=item B<--until> I<cmd>
@@ -82,26 +82,6 @@ search for a command in the sequence exactly matching the name, to avoid any
ambiguity. If there are multiple substring matches, the last one in the
sequence will be used.
-=head1 SEQUENCE ADDONS
-
-When B<--with> I<addon> is used, dh loads the perl module
-Debian::Debhelper::Sequence::I<addon>. Two functions are provided to let
-the module add its commands to sequences:
-
-=over 4
-
-=item Debian::Debhelper::Dh_Lib::insert_before(existing_command, new_command)
-
-Insert I<new_command> in sequences before I<existing_command>.
-
-=item Debian::Debhelper::Dh_Lib::insert_after(existing_command, new_command)
-
-Insert I<new_command> in sequences after I<existing_command>.
-
-=item Debian::Debhelper::Dh_Lib::remove_command(existing_command)
-
-Remove I<existing_command> from the list of commands to run.
-
=back
=cut
diff --git a/doc/PROGRAMMING b/doc/PROGRAMMING
index 5c60a0b1..9963181e 100644
--- a/doc/PROGRAMMING
+++ b/doc/PROGRAMMING
@@ -46,27 +46,19 @@ Debhelper programs should default to doing exactly what policy says to do.
There are always exceptions. Just ask me.
-Introducing Dh_Lib.pm:
----------------------
+Introducing Dh_Lib:
+------------------
-Dh_Lib.pm is the library used by all debhelper programs to parse their
+Dh_Lib is the library used by all debhelper programs to parse their
arguments and set some useful variables. It's not mandatory that your
program use Dh_Lib.pm, but it will make it a lot easier to keep it in sync
with the rest of debhelper if it does, so this is highly encouraged.
-(There used to be a version of Dh_lib.pm that was a library of functions for
-shell scripts. If you want to write a debhelper command that is a shell
-script, I can dig up that old library for you. Only the perl one is
-supported now, though.)
-
-Use Dh_Lib.pm like this:
+Use Dh_Lib like this:
use Debian::Debhelper::Dh_Lib
init();
-The BEGIN block is there to make perl look for the module in all the right
-places.
-
The init() function causes Dh_lib to parse the command line and do some other
initialization tasks.
@@ -258,4 +250,21 @@ write_log($cmd, $package ...)
Writes the log files for the specified package(s), adding
the cmd to the end.
+Sequence Addons
+---------------
+
+The dh(1) command has a --with <addon> parameter that ca be used to load
+a sequence addon named Debian::Debhelper::Sequence::<addon>.
+These addons can add/remove commands to the dh command sequences, by calling
+some functions from Dh_Lib:
+
+insert_before($existing_command, $new_command)
+ Insert $new_command in sequences before $existing_command
+
+insert_after($existing_command, $new_command)
+ Insert $new_command in sequences after $existing_command
+
+remove_command($existing_command)
+ Remove $existing_command from the list of commands to run.
+
-- Joey Hess <joeyh@debian.org>