summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_clean5
2 files changed, 8 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 63d3cd62..b97d5d2f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (7.0.15) UNRELEASED; urgency=low
+
+ * dh_clean: Do not delete *-stamp files in -k mode in v7. Closes: #489918
+
+ -- Joey Hess <joeyh@debian.org> Tue, 08 Jul 2008 13:50:07 -0400
+
debhelper (7.0.14) unstable; urgency=low
* Load python-support sequence file first, to allow ones loaded later to
diff --git a/dh_clean b/dh_clean
index c7465d39..5fd7f936 100755
--- a/dh_clean
+++ b/dh_clean
@@ -36,8 +36,7 @@ clean target in debian/rules.
=item B<-k>, B<--keep>
-This causes L<dh_prep(1)> to be run instead of dh_clean, for backwards
-compatibility.
+This is deprecated, use L<dh_prep(1)> instead.
=item B<-d>, B<--dirs-only>
@@ -122,7 +121,7 @@ if (! $dh{D_FLAG}) {
doit('rm', '-rf', 'debian/tmp') if -x 'debian/tmp' && ! compat(1) &&
! excludefile("debian/tmp");
-if (!compat(6)) {
+if (!compat(6) && !$dh{K_FLAG}) {
complex_doit('rm -f *-stamp');
}