summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdh_builddeb1
-rwxr-xr-xdh_gencontrol1
-rwxr-xr-xdh_installdirs1
-rwxr-xr-xdh_installexamples63
-rw-r--r--dh_installexamples.148
-rwxr-xr-xdh_installinfo70
-rw-r--r--dh_installinfo.157
-rwxr-xr-xdh_installinit87
-rw-r--r--dh_installinit.166
9 files changed, 213 insertions, 181 deletions
diff --git a/dh_builddeb b/dh_builddeb
index adad09dd..162cda86 100755
--- a/dh_builddeb
+++ b/dh_builddeb
@@ -34,6 +34,7 @@ Use this if you want to force the generated .deb file to have a particular
file name. Does not work well if more than one .deb is generated!
=item B<-u>I<params>
+
=item B<--> I<params>
Pass I<params> to L<dpkg(1)|dpkg> when it is used to build the
diff --git a/dh_gencontrol b/dh_gencontrol
index 0c8c88a2..46f192b6 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -26,6 +26,7 @@ This program is merely a wrapper around L<dpkg-gencontrol(1)>.
=over 4
=item B<-u>I<params>, B<--dpkg-gencontrol-params>I<params>
+
=item B<--> I<params>
Pass "params" to L<dpkg-gencontrol(1)>.
diff --git a/dh_installdirs b/dh_installdirs
index e0aae209..4f5cab3c 100755
--- a/dh_installdirs
+++ b/dh_installdirs
@@ -95,4 +95,3 @@ This program is a part of debhelper.
Joey Hess <joeyh@debian.org>
=cut
-
diff --git a/dh_installexamples b/dh_installexamples
index 9fdbdf7c..7c004265 100755
--- a/dh_installexamples
+++ b/dh_installexamples
@@ -1,10 +1,55 @@
#!/usr/bin/perl -w
-#
-# Reads debian/examples, installs all files listed there into
-# /usr/share/doc/$package/examples
+
+=head1 NAME
+
+dh_installexamples - install example files into package build directories
+
+=cut
use strict;
use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+ dh_installexamples [debhelper options] [-A] [file ...]
+
+=head1 DESCRIPTION
+
+dh_installexamples is a debhelper program that is responsible for
+installing examples into usr/share/doc/package/examples in package
+build directories.
+
+Any file names specified as parameters will be installed into the first
+package dh_installexamples is told to act on. By default, this is the first
+binary package in debian/control, but if you use -p, -i, or -a flags, it
+will be the first package specified by those flags.
+
+Files named debian/package.examples can list other files to be installed.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-A>, B<--all>
+
+Install any files specified by command line parameters in ALL packages
+acted on.
+
+=item I<file ...>
+
+Install these files as examples into the first package acted on. (Or into
+all packages if -A is specified.)
+
+=back
+
+=head1 NOTES
+
+Note that dh_installexamples will happily copy entire directory hierarchies
+if you ask it to (it uses cp -a internally). If it is asked to install a
+directory, it will install the complete contents of the directory.
+
+=cut
+
init();
foreach my $package (@{$dh{DOPACKAGES}}) {
@@ -29,3 +74,15 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
doit("cp","-a",@examples,"$tmp/usr/share/doc/$package/examples");
}
}
+
+=head1 SEE ALSO
+
+L<debhelper(1)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
diff --git a/dh_installexamples.1 b/dh_installexamples.1
deleted file mode 100644
index 0bbf43a5..00000000
--- a/dh_installexamples.1
+++ /dev/null
@@ -1,48 +0,0 @@
-.TH DH_INSTALLEXAMPLES 1 "" "Debhelper Commands" "Debhelper Commands"
-.SH NAME
-dh_installexamples \- install example files into package build directories
-.SH SYNOPSIS
-.B dh_installexamples
-.I "[debhelper options] [-A] [file ...]"
-.SH "DESCRIPTION"
-dh_installexamples is a debhelper program that is responsible for installing
-examples into usr/share/doc/package/examples in package build directories.
-.P
-Any file names specified as parameters will be installed into the first
-package dh_installexamples is told to act on. By default, this is the first
-binary package in debian/control, but if you use -p, -i, or -a flags, it
-will be the first package specified by those flags.
-.P
-Files named debian/package.examples can list other files to be installed.
-.SH OPTIONS
-.TP
-.B debhelper options
-See
-.BR debhelper (1)
-for a list of options common to all debhelper commands.
-.TP
-.B \-A, \--all
-Install any files specified by command line parameters in ALL packages
-acted on.
-.TP
-.B file ...
-Install these files as examples into the first package acted on. (Or into all
-packages if -A is specified.)
-.SH NOTES
-Note that dh_installexamples will happily copy entire directory hierarchies if
-you ask it to (it uses cp -a internally). If it is asked to install a
-directory, it will install the complete contents of the directory.
-.SH ENVIRONMENT
-See
-.BR debhelper (1)
-for a list of environment variables that affect all debhelper commands.
-.SH "SEE ALSO"
-.BR debhelper (1)
-.SH BUGS
-It's impossible to specify filenames with spaces or other whitespace in them
-in debian/package.examples file. This is more a historical design flaw than a
-bug.
-.SH "CONFORMS TO"
-Debian policy, version 3.0.1
-.SH AUTHOR
-Joey Hess <joeyh@debian.org>
diff --git a/dh_installinfo b/dh_installinfo
index 702f4ee8..41446fdd 100755
--- a/dh_installinfo
+++ b/dh_installinfo
@@ -1,10 +1,62 @@
#!/usr/bin/perl -w
-#
-# Reads debian/info, installs all files listed there into /usr/share/info
-# and puts appropriate commands into the postinst.
+
+=head1 NAME
+
+dh_installinfo - install and register info files
+
+=cut
use strict;
use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+ dh_installinfo [debhelper options] [-A] [-n] [file ...]
+
+=head1 DESCRIPTION
+
+dh_installinfo is a debhelper program that is responsible for installing
+info files and registering them with install-info.
+
+Any filenames specified as parameters will be installed into the first
+package dh_installinfo is told to act on. By default, this is the first
+binary package in debian/control, but if you use -p, -i, or -a flags, it
+will be the first package specified by those flags.
+
+Files named debian/package.info can list other files to be installed.
+
+dh_installinfo will automatically generate the postinst and prerm commands
+needed to interface with install-info. See L<dh_installdeb(1)> for an
+explanation of how this works.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-A>, B<--all>
+
+Install all files specified by command line parameters in ALL packages
+acted on.
+
+=item B<-n>, B<--noscripts>
+
+Do not modify postinst/prerm scripts.
+
+=item I<file ...>
+
+Install these info files into the first package acted on. (Or in
+all packages if -A is specified).
+
+=back
+
+=head1 NOTES
+
+Note that this command is not idempotent. "dh_clean -k" should be called
+between invocations of this command. Otherwise, it may cause multiple
+instances of the same text to be added to maintainer scripts.
+
+=cut
+
init();
foreach my $package (@{$dh{DOPACKAGES}}) {
@@ -60,3 +112,15 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
}
}
+
+=head1 SEE ALSO
+
+L<debhelper(1)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
diff --git a/dh_installinfo.1 b/dh_installinfo.1
deleted file mode 100644
index 3728dab7..00000000
--- a/dh_installinfo.1
+++ /dev/null
@@ -1,57 +0,0 @@
-.TH DH_INSTALLINFO 1 "" "Debhelper Commands" "Debhelper Commands"
-.SH NAME
-dh_installinfo \- install and register info files
-.SH SYNOPSIS
-.B dh_installinfo
-.I "[debhelper options] [-A] [-n] [file ...]"
-.SH "DESCRIPTION"
-dh_installinfo is a debhelper program that is responsible for installing
-info files and registering them with install-info.
-.P
-Any filenames specified as parameters will be installed into the first
-package dh_installinfo is told to act on. By default, this is the first
-binary package in debian/control, but if you use -p, -i, or -a flags, it
-will be the first package specified by those flags.
-.P
-Files named debian/package.info can list other files to be installed.
-.P
-dh_installinfo will automatically generate the postinst and prerm commands
-needed to interface with install-info. See
-.BR dh_installdeb (1)
-for an explanation of how this works.
-.SH OPTIONS
-.TP
-.B debhelper options
-See
-.BR debhelper (1)
-for a list of options common to all debhelper commands.
-.TP
-.B \-A, \--all
-Install all files specified by command line parameters in ALL packages
-acted on.
-.TP
-.B \-n, \--noscripts
-Do not modify postinst/prerm scripts.
-.TP
-.B file ...
-Install these info files into the first package acted on. (Or in
-all packages if -A is specified).
-.SH ENVIRONMENT
-See
-.BR debhelper (1)
-for a list of environment variables that affect all debhelper commands.
-.SH "SEE ALSO"
-.BR debhelper (1)
-.TP
-.BR install-info (8)
-.SH NOTES
-Note that this command is not idempotent. "dh_clean -k" should be called
-between invocations of this command. Otherwise, it may cause multiple
-instances of the same text to be added to maintainer scripts.
-.SH BUGS
-It's impossible to specify filenames with spaces or other whitespace in them
-in debian/package.info files. This is more a historical design flaw than a bug.
-.SH "CONFORMS TO"
-Debian policy, version 3.0.1
-.SH AUTHOR
-Joey Hess <joeyh@debian.org>
diff --git a/dh_installinit b/dh_installinit
index e7f9b70b..e73aaf50 100755
--- a/dh_installinit
+++ b/dh_installinit
@@ -1,10 +1,79 @@
#!/usr/bin/perl -w
-#
-# Install debian/init[.d], and set up the postinst and postrm for init
-# scripts.
+
+=head1 NAME
+
+dh_installinit - install init scripts into package build directories
+
+=cut
use strict;
use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+ dh_installinit [debhelper options] [--init-script=scriptname]
+ [-n] [-r] [-d] [-uparams] -- [params]
+
+=head1 DESCRIPTION
+
+dh_installinit is a debhelper program that is responsible for installing
+init scripts into package build directories.
+
+It also automatically generates the postinst and postrm and prerm commands
+needed to set up the symlinks in /etc/rc*.d/ and to start and stop the init
+scripts.
+
+If a file named debian/package.init exists, then it is installed into
+etc/init.d/package in the package build directory, with "package" replaced
+by the package name.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-n>, B<--noscripts>
+
+Do not modify postinst/postrm/prerm scripts.
+
+=item B<-r>, B<--no-restart-on-upgrade>
+
+Do not restart daemon on upgrade.
+
+=item B<-d>, B<--remove-d>
+
+Remove trailing "d" from the name of the package, and use the result for the
+filename the init script is installed as in etc/init.d/ . This may be useful
+for daemons with names ending in "d". (Note: this takes precedence over
+the --init-script parameter described below.)
+
+=item B<-u>I<params> B<--update-rcd-params=>I<params>
+
+=item B<--> I<params>
+
+Pass "params" to L<update-rc.d(8)>. If not specified, "defaults" will be
+passed to L<update-rc.d(8)>.
+
+=item B<--init-script=>I<scriptname>
+
+Use "scriptname" as for the filename the init script is installed as in
+etc/init.d/ . This is useful if you need to have an init script with a name
+different from the package's name. Note that if you use this parameter,
+dh_installinit will look to see if a file in the debian/ directory exists
+that looks like "scriptname" or "package.scriptname" and if so will install
+it as the init script in preference to the files it normally installs. This
+feature is really only useful if you need a single package to install more
+than one init script.
+
+=back
+
+=head1 NOTES
+
+Note that this command is not idempotent. "dh_clean -k" should be called
+between invocations of this command. Otherwise, it may cause multiple
+instances of the same text to be added to maintainer scripts.
+
+=cut
+
init();
foreach my $package (@{$dh{DOPACKAGES}}) {
@@ -74,3 +143,15 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
}
}
+
+=head1 SEE ALSO
+
+L<debhelper(1)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
diff --git a/dh_installinit.1 b/dh_installinit.1
deleted file mode 100644
index 62966fe1..00000000
--- a/dh_installinit.1
+++ /dev/null
@@ -1,66 +0,0 @@
-.TH DH_INSTALLINIT 1 "" "Debhelper Commands" "Debhelper Commands"
-.SH NAME
-dh_installinit \- install init scripts into package build directories
-.SH SYNOPSIS
-.B dh_installinit
-.I "[debhelper options] [--init-script=scriptname] [-n] [-r] [-d] [-uparams] -- [params]"
-.SH "DESCRIPTION"
-dh_installinit is a debhelper program that is responsible for installing
-init scripts into package build directories.
-.P
-It also automatically generates the postinst and postrm and prerm commands
-needed to set up the symlinks in /etc/rc*.d/ and to start and stop the init
-scripts.
-.P
-If a file named debian/package.init exists, then it is installed into
-etc/init.d/package in the package build directory, with "package" replaced
-by the package name.
-.SH OPTIONS
-.TP
-.B debhelper options
-See
-.BR debhelper (1)
-for a list of options common to all debhelper commands.
-.TP
-.B \-n, \--noscripts
-Do not modify postinst/postrm/prerm scripts.
-.TP
-.B \-r, \--no-restart-on-upgrade
-Do not restart daemon on upgrade.
-.TP
-.B \-d, \--remove-d
-Remove trailing "d" from the name of the package, and use the result for the
-filename the init script is installed as in etc/init.d/ . This may be useful
-for daemons with names ending in "d". (Note: this takes precedence over
-the --init-script parameter described below.)
-.TP
-.B \-uparams, \--update-rcd-params=params
-.TP
-.B \-\- params
-Pass "params" to
-.BR update-rc.d (8)
-If not specified, "defaults" will be passed to
-.BR update-rc.d (8)
-.TP
-.B \--init-script=scriptname
-Use "scriptname" as for the filename the init script is installed as in
-etc/init.d/ . This is useful if you need to have an init script with a name
-different from the package's name. Note that if you use this parameter,
-dh_installinit will look to see if a file in the debian/ directory exists
-that looks like "scriptname" or "package.scriptname" and if so will install
-it as the init script in preference to the files it normally installs. This
-feature is really only useful if you need a single package to install more
-than one init script.
-.SH ENVIRONMENT
-See
-.BR debhelper (1)
-for a list of environment variables that affect all debhelper commands.
-.SH NOTES
-Note that this command is not idempotent. "dh_clean -k" should be called
-between invocations of this command. Otherwise, it may cause multiple
-instances of the same text to be added to maintainer scripts.
-.SH "SEE ALSO"
-.BR debhelper (1),
-.BR update_rc.d (8)
-.SH AUTHOR
-Joey Hess <joeyh@debian.org>