summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/makefile.pm2
-rw-r--r--debian/changelog8
2 files changed, 9 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/makefile.pm b/Debian/Debhelper/Buildsystem/makefile.pm
index 2c14c151..e106ffd0 100644
--- a/Debian/Debhelper/Buildsystem/makefile.pm
+++ b/Debian/Debhelper/Buildsystem/makefile.pm
@@ -19,7 +19,7 @@ sub exists_make_target {
my $buildpath = $this->get_buildpath();
unshift @opts, "-C", $buildpath if $buildpath ne ".";
open(SAVEDERR, ">&STDERR");
- close STDERR;
+ open(STDERR, ">/dev/null");
open(MAKE, "-|", $this->{makecmd}, @opts, $target);
my $output=<MAKE>;
close MAKE;
diff --git a/debian/changelog b/debian/changelog
index 77f1844d..342f61aa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (7.4.15) UNRELEASED; urgency=low
+
+ * The fix for #563557 caused some new trouble involving makefile
+ that misbehave when stderr is closed. Reopen it to /dev/null
+ when testing for the existance of a makefile target. Closes: #570443
+
+ -- Joey Hess <joeyh@debian.org> Thu, 18 Feb 2010 16:36:18 -0500
+
debhelper (7.4.14) unstable; urgency=low
* dh: Disable option bundling to avoid mis-parsing bundled options such