summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm3
-rw-r--r--debian/changelog6
2 files changed, 9 insertions, 0 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 377454ed..6a79c9ce 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -224,6 +224,9 @@ sub doit_noerror {
if (! $dh{NO_ACT}) {
return (system(@_) == 0)
}
+ else {
+ return 1;
+ }
}
# Run a command and display the command to stdout if verbose mode is on.
diff --git a/debian/changelog b/debian/changelog
index c069f7f6..d30b89cc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (9.20140228) UNRELEASED; urgency=medium
+
+ * Fix breakage in no-act mode introduced in last release.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 28 Feb 2014 14:59:57 -0400
+
debhelper (9.20140227) unstable; urgency=medium
* dh_compress: Avoid compressing .map files, which may be html