summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm5
-rw-r--r--debian/changelog9
2 files changed, 13 insertions, 1 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 915d37af..49d9d6d0 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -264,6 +264,11 @@ sub pkgext { my $package=shift;
my $version=`dpkg-parsechangelog -l$isnative_changelog`;
($dh{VERSION})=$version=~m/Version: (.*)/m;
+ # Did the changelog parse fail?
+ if (! defined $dh{VERSION}) {
+ error("changelog parse failure");
+ }
+
# Is this a native Debian package?
if ($dh{VERSION}=~m/.*-/) {
$isnative_cache{$package}=0;
diff --git a/debian/changelog b/debian/changelog
index f5331352..eb0c4dd8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,13 @@
+debhelper (2.0.92) unstable; urgency=low
+
+ * Detect changelog parse failures and use a better error message.
+ Closes: #62058
+
+ -- Joey Hess <joeyh@debian.org> Sat, 8 Apr 2000 20:02:16 -0700
+
debhelper (2.0.91) unstable; urgency=low
- * Fixed a simmy typo in dh_installmanpages, Closes: #60727
+ * Fixed a silly typo in dh_installmanpages, Closes: #60727
-- Joey Hess <joeyh@debian.org> Sat, 18 Mar 2000 23:23:01 -0800