summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm2
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm2
-rw-r--r--debian/changelog6
3 files changed, 8 insertions, 2 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index 35a23d67..671bca57 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -46,7 +46,7 @@ sub configure {
push @flags, "config=optimize=$ENV{CFLAGS} $ENV{CPPFLAGS}";
}
if ($ENV{LDFLAGS} && ! compat(8)) {
- push @flags, "config=ld=$Config{ld} $ENV{LDFLAGS}";
+ push @flags, "config=ld=$Config{ld} $ENV{CFLAGS} $ENV{LDFLAGS}";
}
$this->do_perl("Build.PL", "installdirs=vendor", @flags, @_);
}
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index 342e0eb8..60cda3d0 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -51,7 +51,7 @@ sub configure {
push @flags, "OPTIMIZE=$ENV{CFLAGS} $ENV{CPPFLAGS}";
}
if ($ENV{LDFLAGS} && ! compat(8)) {
- push @flags, "LD=$Config{ld} $ENV{LDFLAGS}";
+ push @flags, "LD=$Config{ld} $ENV{CFLAGS} $ENV{LDFLAGS}";
}
$this->doit_in_sourcedir("perl", "Makefile.PL", "INSTALLDIRS=vendor",
diff --git a/debian/changelog b/debian/changelog
index e0df68e7..010ebb5b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (9.20120312) UNRELEASED; urgency=low
+
+ * Also include CFLAGS in ld line for perl. Closes: #662666
+
+ -- Joey Hess <joeyh@debian.org> Tue, 13 Mar 2012 14:26:24 -0400
+
debhelper (9.20120311) unstable; urgency=low
* dh_auto_install: Set AM_UPDATE_INFO_DIR=no to avoid automake