summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdh_auto_build58
-rwxr-xr-xdh_auto_configure7
3 files changed, 63 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index ef53597c..8cd39347 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,9 @@ debhelper (6.0.13) UNRELEASED; urgency=low
* dh_auto_configure: New program, automates running ./configure,
Makefile.PL, and python distutils. Calls them with exactly the same
options as cdbs does by default, and allows adding/overriding options.
+ * dh_auto_build: New program, automates building the package by either
+ running make or using setup.py. (Support for cmake and other build systems
+ planned but not yet implemented.)
-- Joey Hess <joeyh@debian.org> Tue, 22 Apr 2008 17:54:20 -0400
diff --git a/dh_auto_build b/dh_auto_build
new file mode 100755
index 00000000..21798cc2
--- /dev/null
+++ b/dh_auto_build
@@ -0,0 +1,58 @@
+#!/usr/bin/perl -w
+
+=head1 NAME
+
+dh_auto_build - automatically builds a package
+
+=cut
+
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+B<dh_auto_build> [S<I<debhelper options>>] [S<B<--> I<params>>]
+
+=head1 DESCRIPTION
+
+dh_auto_build is a debhelper program that tries to automatically
+build a package. If a Makefile is found, this is done by running make.
+If there's a setup.py, it is run to build the package.
+
+This is intended to work for about 90% of packages. If it doesn't work,
+you're encoruaged to skip using dh_auto_build at all, and just run the
+build process manually.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<--> I<params>
+
+Pass "params" to the program that is run. These can be used to suppliment
+or override the standard parameters that dh_auto_build passes.
+
+=back
+
+=cut
+
+init();
+
+if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
+ doit($ENV{MAKE}, @{$dh{U_PARAMS}});
+}
+elsif (-e "setup.py") {
+ doit("python setup.py", "build", @{$dh{U_PARAMS}});
+}
+
+=head1 SEE ALSO
+
+L<debhelper(7)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
diff --git a/dh_auto_configure b/dh_auto_configure
index 27f9065c..4b01889b 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -23,7 +23,7 @@ is found, dh_auto_configure will exit without doing anything.
This is intended to work for about 90% of packages. If it doesn't work,
you're encoruaged to skip using dh_auto_configure at all, and just run
-./configure or its equivilant by hand.
+./configure or its equivilant manually.
=head1 OPTIONS
@@ -85,10 +85,7 @@ if (-x "configure") {
doit("./configure", @opts, @{$dh{U_PARAMS}});
}
elsif (-e "Makefile.PL") {
- doit("perl Makefile.PL", "INSTALLDIRS=vendor", @{$dh{U_PARAMS}});
-}
-elsif (-e "setup.py") {
- doit("python setup.py", "build", @{$dh{U_PARAMS}});
+ doit("perl", "Makefile.PL", "INSTALLDIRS=vendor", @{$dh{U_PARAMS}});
}
=head1 SEE ALSO