summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/autoconf.pm11
-rw-r--r--debhelper.pod5
-rw-r--r--debian/changelog2
3 files changed, 15 insertions, 3 deletions
diff --git a/Debian/Debhelper/Buildsystem/autoconf.pm b/Debian/Debhelper/Buildsystem/autoconf.pm
index 1fbc80de..20b9fd44 100644
--- a/Debian/Debhelper/Buildsystem/autoconf.pm
+++ b/Debian/Debhelper/Buildsystem/autoconf.pm
@@ -38,9 +38,14 @@ sub configure {
push @opts, "--sysconfdir=/etc";
push @opts, "--localstatedir=/var";
my $multiarch=dpkg_architecture_value("DEB_HOST_MULTIARCH");
- if (! compat(8) && defined $multiarch) {
- push @opts, "--libdir=\${prefix}/lib/$multiarch";
- push @opts, "--libexecdir=\${prefix}/lib/$multiarch";
+ if (! compat(8)) {
+ if (defined $multiarch) {
+ push @opts, "--libdir=\${prefix}/lib/$multiarch";
+ push @opts, "--libexecdir=\${prefix}/lib/$multiarch";
+ }
+ else {
+ push @opts, "--libexecdir=\${prefix}/lib";
+ }
}
else {
push @opts, "--libexecdir=\${prefix}/lib/" . sourcepackage();
diff --git a/debhelper.pod b/debhelper.pod
index 9939ea13..d61cc84d 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -550,6 +550,11 @@ while B<dh_makeshlibs> detects packages containing multiarch
directories and sets a Pre-Dependency on multiarch-support in
${misc:Pre-Depends}
+=item -
+
+B<dh_auto_configure> does not include the source package name
+in --libexecdir when using autoconf.
+
=back
=back
diff --git a/debian/changelog b/debian/changelog
index 8404462d..35692dad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ debhelper (8.1.7) UNRELEASED; urgency=low
* Fix example. Closes: #627534
* Fix error message. Closes: #628053
* dh_movefiles: Optimise use of xargs. Closes: #627737
+ * dh_auto_configure: In v9, does not include the source package name
+ in --libexecdir when using autoconf. Closes: #541458
-- Joey Hess <joeyh@debian.org> Sat, 21 May 2011 15:24:19 -0400