summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_clean3
-rwxr-xr-xdh_link4
3 files changed, 12 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e5e06fe2..e305c64a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.1.66) unstable; urgency=low
+
+ * dh_link: rm -f every time, ln -f is not good enough if the link target
+ is an existing directory (aka, ln sucks). Closes: #206245
+ * dh_clean: honor -X for debian/tmp removal. Closes: #199952 more or less.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 19 Aug 2003 19:52:53 -0400
+
debhelper (4.1.65) unstable; urgency=low
* Converted several chown 0.0 to chown 0:0 for POSIX 200112.
diff --git a/dh_clean b/dh_clean
index d4c5943a..9b5885fe 100755
--- a/dh_clean
+++ b/dh_clean
@@ -106,7 +106,8 @@ if (! $dh{D_FLAG}) {
unless excludefile("autom4te.cache");
}
-doit('rm', '-rf', 'debian/tmp') if -x 'debian/tmp' && ! compat(1);
+doit('rm', '-rf', 'debian/tmp') if -x 'debian/tmp' && ! compat(1) &&
+ ! excludefile("debian/tmp");
=head1 SEE ALSO
diff --git a/dh_link b/dh_link
index 6cb889cd..8e66d671 100755
--- a/dh_link
+++ b/dh_link
@@ -119,7 +119,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
push @links, "$dir/$target";
}
push @links, "$dir/$_";
- doit("rm","-f",$_);
},
$tmp);
@@ -164,7 +163,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$src="/$src";
}
- doit("ln","-sf",$src,"$tmp/$dest");
+ doit("rm", "-f", "$tmp/$dest");
+ doit("ln","-sf", $src, "$tmp/$dest");
}
}