summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdh_auto_configure2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 05369192..7ef8a63c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,9 @@ debhelper (7.2.10) UNRELEASED; urgency=low
* Close COMPAT_IN filehandle. Closes: #527464
* dh_auto_configure: Clarify man page re adding configure
parameters. Closes: #527256
+ * dh_auto_configure: Pass packlist=0 when running Makefile.PL,
+ in case it is a Build.PL passthru, to avoid it creating
+ the .packlist file. Closes: #527990
-- Joey Hess <joeyh@debian.org> Thu, 07 May 2009 16:33:25 -0400
diff --git a/dh_auto_configure b/dh_auto_configure
index da1f7511..2dc3eb32 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -91,7 +91,7 @@ elsif (-e "Makefile.PL") {
# If set to a true value then MakeMaker's prompt function will
# # always return the default without waiting for user input.
$ENV{PERL_MM_USE_DEFAULT}=1;
- doit("perl", "Makefile.PL", "INSTALLDIRS=vendor", @{$dh{U_PARAMS}});
+ doit("perl", "Makefile.PL", "INSTALLDIRS=vendor", "create_packlist=0", @{$dh{U_PARAMS}});
}
elsif (-e "Build.PL") {
$ENV{PERL_MM_USE_DEFAULT}=1; # Module::Build can also use this.