summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm2
-rw-r--r--debian/changelog6
2 files changed, 7 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index 98029efd..f318b44b 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -44,7 +44,7 @@ sub configure {
push @flags, "-DCMAKE_VERBOSE_MAKEFILE=ON";
# CMake doesn't respect CPPFLAGS, see #653916.
- if ($ENV{CPPFLAGS}) {
+ if ($ENV{CPPFLAGS} && ! compat(8)) {
$ENV{CFLAGS} .= ' ' . $ENV{CPPFLAGS};
$ENV{CXXFLAGS} .= ' ' . $ENV{CPPFLAGS};
}
diff --git a/debian/changelog b/debian/changelog
index 86d4565e..7d85a5ef 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (9.20120418) unstable; urgency=low
+
+ * cmake: Only pass CPPFLAGS in CFLAGS in v9.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 17 Apr 2012 16:54:39 -0400
+
debhelper (9.20120417) unstable; urgency=low
* cmake: Pass CPPFLAGS in CFLAGS. Closes: #668813