summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_md5sums3
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 092fb6ad..6d504a0a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.2.34) unstable; urgency=low
+
+ * The infinite number of monkeys release.
+ * dh_md5sums: don't crash if PWD contains an apostrophe. Closes: #305226
+
+ -- Joey Hess <joeyh@debian.org> Wed, 20 Apr 2005 21:06:43 -0400
+
debhelper (4.2.33) unstable; urgency=low
* Update Spanish translation of dh_clean man page. Closes: #303052
diff --git a/dh_md5sums b/dh_md5sums
index 8fd8b2eb..a53603e1 100755
--- a/dh_md5sums
+++ b/dh_md5sums
@@ -72,8 +72,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$exclude.="! \\( $dh{EXCLUDE_FIND} \\) ";
}
- my $olddir=getcwd();
- complex_doit("cd $tmp >/dev/null ; find . -type f $exclude ! -regex '.*/DEBIAN/.*' -printf '%P\\0' | xargs -r0 md5sum > DEBIAN/md5sums ; cd '$olddir' >/dev/null");
+ complex_doit("(cd $tmp >/dev/null ; find . -type f $exclude ! -regex '.*/DEBIAN/.*' -printf '%P\\0' | xargs -r0 md5sum > DEBIAN/md5sums) >/dev/null");
# If the file's empty, no reason to waste inodes on it.
if (-z "$tmp/DEBIAN/md5sums") {
doit("rm","-f","$tmp/DEBIAN/md5sums");