summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_installdocs5
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ebf733ca..ec619128 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ debhelper (9.20131228) UNRELEASED; urgency=medium
* dh_compress: Avoid compressing .map files, which may be html
usemaps. Closes: #704443
+ * dh_installdocs: When doc dirs are symlinked make the dependency
+ versioned per policy. Closes: #676777
-- Joey Hess <joeyh@debian.org> Sat, 25 Jan 2014 15:49:45 -0400
diff --git a/dh_installdocs b/dh_installdocs
index e835ff69..3eefcdfa 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -175,10 +175,13 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (! -d "$tmp/usr/share/doc/$package" &&
! -l "$tmp/usr/share/doc/$package") {
doit("ln", "-sf", $dh{LINK_DOC}, "$tmp/usr/share/doc/$package");
+ # Call isnative because it sets $dh{VERSION}
+ # as a side effect.
+ isnative($dh{LINK_DOC});
# Policy says that if you make your documentation
# directory a symlink, then you have to depend on
# the target.
- addsubstvar($package, "misc:Depends", $dh{LINK_DOC});
+ addsubstvar($package, "misc:Depends", "$dh{LINK_DOC} (= $dh{VERSION})");
}
}
else {