summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/cmake.pm
diff options
context:
space:
mode:
Diffstat (limited to 'Debian/Debhelper/Buildsystem/cmake.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm5
1 files changed, 4 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index 645c8c03..03e6ade5 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -17,7 +17,10 @@ sub check_auto_buildable {
my $this=shift;
my ($step)=@_;
my $ret = -e $this->get_sourcepath("CMakeLists.txt");
- $ret &&= $this->SUPER::check_auto_buildable(@_) if $step ne "configure";
+ if ($step ne "configure") {
+ $ret &&= -e $this->get_buildpath("CMakeCache.txt") &&
+ $this->SUPER::check_auto_buildable(@_);
+ }
return $ret;
}