summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/perl_build.pm
diff options
context:
space:
mode:
Diffstat (limited to 'Debian/Debhelper/Buildsystem/perl_build.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm8
1 files changed, 0 insertions, 8 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index 63655304..d6bd063b 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -19,14 +19,6 @@ sub check_auto_buildable {
# Handles everything
my $ret = -e "Build.PL";
- # XXX JEH what happens here if they run dh_auto_build,
- # forgetting dh_auto_configure? I think it will just
- # think it's not auto buildable and, assuming no other buildsystems
- # succeed, silently do nothing. Perhaps it would be better, then,
- # to omit the test below. Then, it would try to run ./Build
- # which doesn't exist, which should result in a semi-useful error.
- # XXX MDX Agreed. But it would not be fully backwards compatible
- # (see comment in autotools.mk why). Your call.
if ($action ne "configure") {
$ret &&= -e "Build";
}