summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/python_distutils.pm
diff options
context:
space:
mode:
Diffstat (limited to 'Debian/Debhelper/Buildsystem/python_distutils.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm18
1 files changed, 9 insertions, 9 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 0061a442..e34183c6 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -20,29 +20,29 @@ sub check_auto_buildable {
}
sub setup_py {
- my $self=shift;
+ my $this=shift;
my $act=shift;
- if ($self->get_builddir()) {
- unshift @_, "--build-base=" . $self->get_builddir();
+ if ($this->get_builddir()) {
+ unshift @_, "--build-base=" . $this->get_builddir();
}
doit("python", "setup.py", $act, @_);
}
sub build {
- my $self=shift;
- $self->setup_py("build", @_);
+ my $this=shift;
+ $this->setup_py("build", @_);
}
sub install {
- my $self=shift;
+ my $this=shift;
my $destdir=shift;
- $self->setup_py("install", "--root=$destdir", "--no-compile", "-O0", @_);
+ $this->setup_py("install", "--root=$destdir", "--no-compile", "-O0", @_);
}
sub clean {
- my $self=shift;
- $self->setup_py("clean", "-a", @_);
+ my $this=shift;
+ $this->setup_py("clean", "-a", @_);
# The setup.py might import files, leading to python creating pyc
# files.
doit('find', '.', '-name', '*.pyc', '-exec', 'rm', '{}', ';');