summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/python_distutils.pm
diff options
context:
space:
mode:
Diffstat (limited to 'Debian/Debhelper/Buildsystem/python_distutils.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm10
1 files changed, 5 insertions, 5 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 4e98226d..e1b1aef0 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -90,11 +90,11 @@ sub dbg_build_needed {
# built in a clean chroot.
my @dbg;
- open (CONTROL, $this->get_sourcepath('debian/control')) ||
+ open (CONTROL, 'debian/control') ||
error("cannot read debian/control: $!\n");
foreach my $builddeps (join('', <CONTROL>) =~
/^Build-Depends[^:]*:.*\n(?:^[^\w\n].*\n)*/gmi) {
- foreach ($builddeps =~ /(python[^, ]*-dbg)/g) {
+ while ($builddeps =~ /(python[^, ]*-dbg)/g) {
push @dbg, $1;
}
}
@@ -120,8 +120,8 @@ sub setup_py {
$python_default =~ s/^\s+//;
$python_default =~ s/\s+$//;
my @python_requested = split ' ', `pyversions -r 2>/dev/null`;
- if (grep /^$python_default/, @python_requested) {
- @python_requested = ("python", grep(!/^$python_default/,
+ if (grep /^\Q$python_default\E/, @python_requested) {
+ @python_requested = ("python", grep(!/^\Q$python_default\E/,
@python_requested));
}
my @dbg_build_needed = $this->dbg_build_needed();
@@ -131,7 +131,7 @@ sub setup_py {
$this->doit_in_sourcedir($python, "setup.py", $act, @_);
}
$python = $python . "-dbg";
- if (grep /^(python-all-dbg|$python)/, @dbg_build_needed) {
+ if (grep /^(python-all-dbg|\Q$python\E)/, @dbg_build_needed) {
$this->doit_in_sourcedir($python, "setup.py", $act, @_);
} elsif (($python eq "python-dbg")
and (grep /^$python_default/, @dbg_build_needed)) {