summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/python_distutils.pm
diff options
context:
space:
mode:
Diffstat (limited to 'Debian/Debhelper/Buildsystem/python_distutils.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm49
1 files changed, 21 insertions, 28 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 2e7eacbb..a69b36f4 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -9,54 +9,47 @@ package Debian::Debhelper::Buildsystem::python_distutils;
use strict;
use Debian::Debhelper::Dh_Lib;
-use Debian::Debhelper::Dh_Buildsystem_Bases;
-use base 'Debian::Debhelper::Dh_Buildsystem_Option';
+use base 'Debian::Debhelper::Dh_Buildsystem_Basic';
sub DESCRIPTION {
"support for building Python distutils based packages"
}
-sub is_buildable {
- return -e "setup.py";
+sub is_auto_buildable {
+ my $self=shift;
+ my $action=shift;
+
+ # Handle build install clean; the rest - next class
+ if (grep(/^\Q$action\E$/, qw{build install clean})) {
+ return -e "setup.py";
+ }
+ return 0;
}
-sub get_builddir_option {
+sub setup_py {
my $self=shift;
+ my $act=shift;
+
if ($self->get_builddir()) {
- return "--build-base=". $self->get_builddir();
+ unshift @_, "--build-base=" . $self->get_builddir();
}
- return;
+ doit("python", "setup.py", $act, @_);
}
-# XXX JEH the default for all these methods is to do nothing successfully.
-# So either this, or those default stubs, need to be removed.
-sub configure_impl {
- # Do nothing
- 1;
-}
-
-sub build_impl {
+sub build {
my $self=shift;
- doit("python", "setup.py", "build", @_);
-}
-
-# XXX JEH see anove comment
-sub test_impl {
- 1;
+ $self->setup_py("build", @_);
}
-sub install_impl {
+sub install {
my $self=shift;
my $destdir=shift;
-
- doit("python", "setup.py", "install",
- "--root=$destdir",
- "--no-compile", "-O0", @_);
+ $self->setup_py("install", "--root=$destdir", "--no-compile", "-O0", @_);
}
-sub clean_impl {
+sub clean {
my $self=shift;
- doit("python", "setup.py", "clean", "-a", @_);
+ $self->setup_py("clean", "-a", @_);
# The setup.py might import files, leading to python creating pyc
# files.
doit('find', '.', '-name', '*.pyc', '-exec', 'rm', '{}', ';');