summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem
diff options
context:
space:
mode:
Diffstat (limited to 'Debian/Debhelper/Buildsystem')
-rw-r--r--Debian/Debhelper/Buildsystem/autotools.pm8
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm16
-rw-r--r--Debian/Debhelper/Buildsystem/makefile.pm50
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm30
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm14
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm18
6 files changed, 68 insertions, 68 deletions
diff --git a/Debian/Debhelper/Buildsystem/autotools.pm b/Debian/Debhelper/Buildsystem/autotools.pm
index 0f112618..edebd98d 100644
--- a/Debian/Debhelper/Buildsystem/autotools.pm
+++ b/Debian/Debhelper/Buildsystem/autotools.pm
@@ -16,7 +16,7 @@ sub DESCRIPTION {
}
sub check_auto_buildable {
- my $self=shift;
+ my $this=shift;
my ($action)=@_;
# Handle configure; the rest - next class
@@ -27,7 +27,7 @@ sub check_auto_buildable {
}
sub configure {
- my $self=shift;
+ my $this=shift;
# Standard set of options for configure.
my @opts;
@@ -49,8 +49,8 @@ sub configure {
push @opts, "--host=" . dpkg_architecture_value("DEB_HOST_GNU_TYPE");
}
- $self->mkdir_builddir();
- $self->doit_in_builddir($self->get_rel2builddir_path("configure"), @opts, @_);
+ $this->mkdir_builddir();
+ $this->doit_in_builddir($this->get_rel2builddir_path("configure"), @opts, @_);
}
1;
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index f40b020f..fe91503c 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -15,23 +15,23 @@ sub DESCRIPTION {
}
sub check_auto_buildable {
- my $self=shift;
+ my $this=shift;
my ($action)=@_;
my $ret = -e "CMakeLists.txt";
- $ret &&= $self->SUPER::check_auto_buildable(@_) if $action ne "configure";
+ $ret &&= $this->SUPER::check_auto_buildable(@_) if $action ne "configure";
return $ret;
}
sub new {
my $class=shift;
- my $self=$class->SUPER::new(@_);
+ my $this=$class->SUPER::new(@_);
# Enforce outside-source tree builds.
- $self->enforce_outside_source_building();
- return $self;
+ $this->enforce_outside_source_building();
+ return $this;
}
sub configure {
- my $self=shift;
+ my $this=shift;
my @flags;
# Standard set of cmake flags
@@ -42,8 +42,8 @@ sub configure {
push @flags, "-DCMAKE_SKIP_RPATH=ON";
push @flags, "-DCMAKE_VERBOSE_MAKEFILE=ON";
- $self->mkdir_builddir();
- $self->doit_in_builddir("cmake", $self->get_rel2builddir_path(), @flags);
+ $this->mkdir_builddir();
+ $this->doit_in_builddir("cmake", $this->get_rel2builddir_path(), @flags);
}
1;
diff --git a/Debian/Debhelper/Buildsystem/makefile.pm b/Debian/Debhelper/Buildsystem/makefile.pm
index 0eab0c4a..2d4c64ca 100644
--- a/Debian/Debhelper/Buildsystem/makefile.pm
+++ b/Debian/Debhelper/Buildsystem/makefile.pm
@@ -11,16 +11,16 @@ use Debian::Debhelper::Dh_Lib;
use base 'Debian::Debhelper::Dh_Buildsystem';
sub get_makecmd_C {
- my $self=shift;
- if ($self->get_builddir()) {
- return $self->{makecmd} . " -C " . $self->get_builddir();
+ my $this=shift;
+ if ($this->get_builddir()) {
+ return $this->{makecmd} . " -C " . $this->get_builddir();
}
- return $self->{makecmd};
+ return $this->{makecmd};
}
sub exists_make_target {
- my ($self, $target) = @_;
- my $makecmd=$self->get_makecmd_C();
+ my ($this, $target) = @_;
+ my $makecmd=$this->get_makecmd_C();
# Use make -n to check to see if the target would do
# anything. There's no good way to test if a target exists.
@@ -30,12 +30,12 @@ sub exists_make_target {
}
sub make_first_existing_target {
- my $self=shift;
+ my $this=shift;
my $targets=shift;
foreach my $target (@$targets) {
- if ($self->exists_make_target($target)) {
- $self->doit_in_builddir($self->{makecmd}, $target, @_);
+ if ($this->exists_make_target($target)) {
+ $this->doit_in_builddir($this->{makecmd}, $target, @_);
return $target;
}
}
@@ -48,46 +48,46 @@ sub DESCRIPTION {
sub new {
my $class=shift;
- my $self=$class->SUPER::new(@_);
- $self->{makecmd} = (exists $ENV{MAKE}) ? $ENV{MAKE} : "make";
- return $self;
+ my $this=$class->SUPER::new(@_);
+ $this->{makecmd} = (exists $ENV{MAKE}) ? $ENV{MAKE} : "make";
+ return $this;
}
sub check_auto_buildable {
- my $self=shift;
+ my $this=shift;
my ($action) = @_;
# Handles build, test, install, clean; configure - next class
if (grep /^\Q$action\E$/, qw{build test install clean}) {
# This is always called in the source directory, but generally
# Makefiles are created (or live) in the the build directory.
- return -e $self->get_buildpath("Makefile") ||
- -e $self->get_buildpath("makefile") ||
- -e $self->get_buildpath("GNUmakefile");
+ return -e $this->get_buildpath("Makefile") ||
+ -e $this->get_buildpath("makefile") ||
+ -e $this->get_buildpath("GNUmakefile");
}
return 0;
}
sub build {
- my $self=shift;
- $self->doit_in_builddir($self->{makecmd}, @_);
+ my $this=shift;
+ $this->doit_in_builddir($this->{makecmd}, @_);
}
sub test {
- my $self=shift;
- $self->make_first_existing_target(['test', 'check'], @_);
+ my $this=shift;
+ $this->make_first_existing_target(['test', 'check'], @_);
}
sub install {
- my $self=shift;
+ my $this=shift;
my $destdir=shift;
- $self->make_first_existing_target(['install'], "DESTDIR=$destdir", @_);
+ $this->make_first_existing_target(['install'], "DESTDIR=$destdir", @_);
}
sub clean {
- my $self=shift;
- if (!$self->clean_builddir()) {
- $self->make_first_existing_target(['distclean', 'realclean', 'clean'], @_);
+ my $this=shift;
+ if (!$this->clean_builddir()) {
+ $this->make_first_existing_target(['distclean', 'realclean', 'clean'], @_);
}
}
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index 03608564..b5ad96df 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -15,7 +15,7 @@ sub DESCRIPTION {
}
sub check_auto_buildable {
- my ($self, $action) = @_;
+ my ($this, $action) = @_;
# Handles everything
my $ret = -e "Build.PL";
@@ -26,43 +26,43 @@ sub check_auto_buildable {
}
sub do_perl {
- my $self=shift;
+ my $this=shift;
$ENV{MODULEBUILDRC} = "/dev/null";
doit("perl", @_);
}
sub new {
my $class=shift;
- my $self= $class->SUPER::new(@_);
- $self->enforce_in_source_building();
- return $self;
+ my $this= $class->SUPER::new(@_);
+ $this->enforce_in_source_building();
+ return $this;
}
sub configure {
- my $self=shift;
+ my $this=shift;
$ENV{PERL_MM_USE_DEFAULT}=1;
- $self->do_perl("Build.PL", "installdirs=vendor", @_);
+ $this->do_perl("Build.PL", "installdirs=vendor", @_);
}
sub build {
- my $self=shift;
- $self->do_perl("Build", @_);
+ my $this=shift;
+ $this->do_perl("Build", @_);
}
sub test {
- my $self=shift;
- $self->do_perl("Build", "test", @_);
+ my $this=shift;
+ $this->do_perl("Build", "test", @_);
}
sub install {
- my $self=shift;
+ my $this=shift;
my $destdir=shift;
- $self->do_perl("Build", "install", "destdir=$destdir", "create_packlist=0", @_);
+ $this->do_perl("Build", "install", "destdir=$destdir", "create_packlist=0", @_);
}
sub clean {
- my $self=shift;
- $self->do_perl("Build", "--allow_mb_mismatch", 1, "distclean", @_);
+ my $this=shift;
+ $this->do_perl("Build", "--allow_mb_mismatch", 1, "distclean", @_);
}
1;
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index 74eaf6bf..1d08dd66 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -15,7 +15,7 @@ sub DESCRIPTION {
}
sub check_auto_buildable {
- my $self=shift;
+ my $this=shift;
my ($action)=@_;
# Handles configure, install; the rest - next class
@@ -29,13 +29,13 @@ sub check_auto_buildable {
sub new {
my $class=shift;
- my $self=$class->SUPER::new(@_);
- $self->enforce_in_source_building();
- return $self;
+ my $this=$class->SUPER::new(@_);
+ $this->enforce_in_source_building();
+ return $this;
}
sub configure {
- my $self=shift;
+ my $this=shift;
# If set to a true value then MakeMaker's prompt function will
# # always return the default without waiting for user input.
$ENV{PERL_MM_USE_DEFAULT}=1;
@@ -43,9 +43,9 @@ sub configure {
}
sub install {
- my $self=shift;
+ my $this=shift;
my $destdir=shift;
- $self->SUPER::install($destdir, "PREFIX=/usr", @_);
+ $this->SUPER::install($destdir, "PREFIX=/usr", @_);
}
1;
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 0061a442..e34183c6 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -20,29 +20,29 @@ sub check_auto_buildable {
}
sub setup_py {
- my $self=shift;
+ my $this=shift;
my $act=shift;
- if ($self->get_builddir()) {
- unshift @_, "--build-base=" . $self->get_builddir();
+ if ($this->get_builddir()) {
+ unshift @_, "--build-base=" . $this->get_builddir();
}
doit("python", "setup.py", $act, @_);
}
sub build {
- my $self=shift;
- $self->setup_py("build", @_);
+ my $this=shift;
+ $this->setup_py("build", @_);
}
sub install {
- my $self=shift;
+ my $this=shift;
my $destdir=shift;
- $self->setup_py("install", "--root=$destdir", "--no-compile", "-O0", @_);
+ $this->setup_py("install", "--root=$destdir", "--no-compile", "-O0", @_);
}
sub clean {
- my $self=shift;
- $self->setup_py("clean", "-a", @_);
+ my $this=shift;
+ $this->setup_py("clean", "-a", @_);
# The setup.py might import files, leading to python creating pyc
# files.
doit('find', '.', '-name', '*.pyc', '-exec', 'rm', '{}', ';');