summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem
diff options
context:
space:
mode:
Diffstat (limited to 'Debian/Debhelper/Buildsystem')
-rw-r--r--Debian/Debhelper/Buildsystem/autoconf.pm2
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm6
-rw-r--r--Debian/Debhelper/Buildsystem/makefile.pm2
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm2
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm2
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm6
6 files changed, 10 insertions, 10 deletions
diff --git a/Debian/Debhelper/Buildsystem/autoconf.pm b/Debian/Debhelper/Buildsystem/autoconf.pm
index c92e2c1f..60fa9e85 100644
--- a/Debian/Debhelper/Buildsystem/autoconf.pm
+++ b/Debian/Debhelper/Buildsystem/autoconf.pm
@@ -1,4 +1,4 @@
-# A buildsystem plugin for handling autoconf based projects
+# A debhelper build system class for handling Autoconf based projects
#
# Copyright: © 2008 Joey Hess
# © 2008-2009 Modestas Vainius
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index 057f327b..c2a3769d 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -1,5 +1,5 @@
-# A buildsystem plugin for handling CMake based projects.
-# It enforces out of source tree building.
+# A debhelper build system class for handling CMake based projects.
+# It prefers out of source tree building.
#
# Copyright: © 2008-2009 Modestas Vainius
# License: GPL-2+
@@ -25,7 +25,7 @@ sub new {
my $class=shift;
my $this=$class->SUPER::new(@_);
my %args=@_;
- # Enforce out of source tree building (soft mode).
+ # Prefer out of source tree building.
$this->enforce_out_of_source_building($args{builddir});
return $this;
}
diff --git a/Debian/Debhelper/Buildsystem/makefile.pm b/Debian/Debhelper/Buildsystem/makefile.pm
index 6a9e6877..d84d3349 100644
--- a/Debian/Debhelper/Buildsystem/makefile.pm
+++ b/Debian/Debhelper/Buildsystem/makefile.pm
@@ -1,4 +1,4 @@
-# A buildsystem plugin for handling simple Makefile based projects.
+# A debhelper build system class for handling simple Makefile based projects.
#
# Copyright: © 2008 Joey Hess
# © 2008-2009 Modestas Vainius
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index 525b0e1c..3567cb1a 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -1,4 +1,4 @@
-# A buildsystem plugin for handling Perl Build based projects.
+# A build system class for handling Perl Build based projects.
#
# Copyright: © 2008-2009 Joey Hess
# © 2008-2009 Modestas Vainius
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index 4281fa26..07a827ac 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -1,4 +1,4 @@
-# A buildsystem plugin for handling Perl MakeMaker based projects.
+# A debhelper build system class for handling Perl MakeMaker based projects.
#
# Copyright: © 2008-2009 Joey Hess
# © 2008-2009 Modestas Vainius
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 26411736..d05e3815 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -1,5 +1,5 @@
-# A buildsystem plugin for building Python Distutils based
-# projects.
+# A debhelper build system class for building Python Distutils based
+# projects. It prefers out of source tree building.
#
# Copyright: © 2008 Joey Hess
# © 2008-2009 Modestas Vainius
@@ -13,7 +13,7 @@ use Debian::Debhelper::Dh_Lib qw(error);
use base 'Debian::Debhelper::Buildsystem';
sub DESCRIPTION {
- "Python distutils"
+ "Python Distutils (setup.py)"
}
sub DEFAULT_BUILD_DIRECTORY {