summaryrefslogtreecommitdiff
path: root/Debian/Debhelper
diff options
context:
space:
mode:
Diffstat (limited to 'Debian/Debhelper')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm6
1 files changed, 3 insertions, 3 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 9468e38f..502bf24f 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -89,9 +89,9 @@ sub setup_py {
# We need to to run setup.py with the default python first
# as distutils/setuptools modifies the shebang lines of scripts.
# This ensures that #!/usr/bin/python is used and not pythonX.Y
- $this->doit_in_sourcedir("python", "setup.py", $act, @_);
- for my $python (grep(!/^$python_default/, (split ' ', `pyversions -r 2>/dev/null`))) {
- if (-x "/usr/bin/" . $python) {
+ foreach my $python ("python", grep(!/^$python_default/,
+ (split ' ', `pyversions -r 2>/dev/null`))) {
+ if (-x "/usr/bin/".$python) {
$this->doit_in_sourcedir($python, "setup.py", $act, @_);
}
}